Email Automation is not working

I'm trying to create some workflows with email automation and none of them seem to be working.

Answers

  • My co-worker who also has a developer license is not having issues. He can get into our sheets and create the exact same flow and it is working fine.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Pallen72

    There are a few reasons why an email may not be received from an automated workflow. The first thing I would check is if your personal settings allow for changes that you make to send yourself alerts:

    If you have this box checked and you see a notification in the bell icon, but not an email, please check your Spam folder or email security settings. Here's more information: Issue: Email not received from Smartsheet

    If this hasn't helped, can you post a screen capture of the workflow you have set up and explain how you're triggering it? (Manual trigger, change in a sheet, formula updating a cell or a manual change, etc).

    Cheers,

    Genevieve

  • Thank you very much Genevieve! That helped resolve most of my issues. I am still struggling with a notification automation with a condition. I'm for 2 fields to be populated on a row to send communication to a group. However, currently I cannot get the communication to trigger. Please see the screenshot below.



  • Genevieve P.
    Genevieve P. Employee Admin

    Hey @Pallen72

    Is there any chance the value in your multi-select cell does not exactly match "Canada"? Can you post a screen capture of the row you submitted with the correct criteria? (With example/test data, not live data)

  • Genevieve,

    It is a drop-down list in that particular column for Canada. That same drop-down list is what populates when trying to create the workflow.



  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Pallen72

    These two workflows look to be different, which one is the one you're testing?

    In any case, thank you for the screen captures and for confirming that "Canada" is a single-select dropdown, this helps.

    The next thing to check is if the users selected in the "Send to specific people" section are shared to the sheet or not. If they're not shared to the sheet, you'll need to adjust your Workflow permissions to allow external users to receive notifications:

    If your settings are already like this, can you confirm if the workflow has ever ran successfully?

    Thanks!

    Genevieve

  • Hey Genevieve,

    Apologies that was a different flow in the 2nd screenshot. I just tried to do it in reverse to see if that would work. Neither instance worked. All recipients have access to the file and unrestricted is checked. The flow has not run successfully. I've tried to run it to myself and to the users. Verified all user emails are correct as well.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hey @Pallen72

    I would suggest going with your first workflow set-up, if you want your users to be alerted any time there's a change in the Tracking column where the row says "Canada". The Canada field would need to be populated when the Tracking changes.

    If you don't see any date underneath the workflow where it says "Last Ran", this indicates that the workflow is not reading a change in the Tracking column OR that it cannot find a match for "Canada".

    Here's how I would test:

    • Set up an alert (to yourself) based purely on the Ship to Country being selected as "Canada"
    • Set up a second alert (to yourself) based purely on the Tracking column changing

    Add a row that has both a value in the Tracking column and Canada selected. Wait up to 5 minutes to see which alert appears in your Smartsheet bell icon.

    If only one of the alerts appears, this tells us which one of the criteria your current workflow is using to filter out and pause the workflow instead of sending it. Does that make sense?