Update request

Options
JenaW
JenaW ✭✭
edited 02/13/24 in Smartsheet Basics

I have a form that sales reps fills out. They filled out the form 4 times for 4 different tradeshows. I have an automation that asks for an update request but in this update request it shows ALL 4 tradeshows and makes them submit the update request all at once.....why is this happening.


Here is my automation


Answers

  • Ric T
    Ric T ✭✭✭✭✭✭
    Options

    Hi @JenaW,

    Looks like you'll need to apply a condition. One idea is to create a new column (or you may already have one) titled "Tradeshow name", change the column type to a dropdown list, list the 4 Values and restrict to list values only.

    After assigning the tradeshow names, update the update request automation and "add a condition to filter rows", apply the filter "tradeshow name" so that your sales rep only receive the relevant update request. Although you could, there's no need to share the "tradeshow name" in the "messages include specific field" because that's really just for you to monitor in the back end.

    Cheers,

    Ric

  • JenaW
    JenaW ✭✭
    Options

    @Ric T I can't list 4 values in the dropdown list because there aren't specific values. It could be named anything.

  • JenaW
    JenaW ✭✭
    Options

    Does anyone know an easy fix for this?

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @JenaW

    Your Update Requests are being batched together due to the trigger being "When a date is reached". This will look at the sheet and send all rows that meet your criteria (the Date Approved date) to the person assigned in the Email cell.

    You can parse out the emails if the trigger is set to be when an action happens, instead of based on a date (with the date as a filter in a Condition block perhaps?) Then if you add {{Placeholders}} to the body of the message in the Update Request, as long as there are only 6 or fewer rows, these will be individual emails.

    See: Tips for working with placeholders

    Cheers,

    Genevieve