Can't select Latest Comment in the edit column properties

Options

I would like to use the "Latest Comment" functionality on a series of sheets. Unfortunately, that Column Type is greyed out and doesn't allow me to select it under the edit column properties.

I am the Owner of the sheet. This is under an enterprise license structure.

In the past, I have used the latest comment functionality on sheets without issue. That functionality is still working on those sheets.

Any thoughts on what may be the issue?

Answers

  • AravindGP
    AravindGP ✭✭✭✭✭
    Options

    Hi @AaronM


    If you already have the Latest Comment column added to your sheet, it will be greyed out as you can have only one such column in a sheet. Check if you already have it added to your sheet as there's an option to change the name of the column.

    Thanks,

    Aravind

    Reach out for any help on licenses, configuration, or training

  • AaronM
    AaronM ✭✭✭
    Options

    Thank you, Aravind.

    I have verified that I do not have a column with that property added to the sheet already. I also created a new sheet and tried to add that column. Unfortunately, still greyed out.

  • Humashankar
    Humashankar ✭✭✭✭✭
    Options

    workspace-level settings impacting column options in the sheet seetings could cause this issue.

    Any other peers facing the same issue or it is only you ?

    Warm regards

    Huma

    Community Leader

  • AaronM
    AaronM ✭✭✭
    Options

    Thank you, Humashankar.

    I have verified that another user is also experiencing the same issue.

    I have checked that the functionality isn't available for new sheets in any existing workspaces. I have also created a sheet outside of a workspace and the functionality didn't exist.

    I have put in a support ticket with SmartSheet Support. More than likely an account setting or license issue.

  • Sheryl P
    Sheryl P ✭✭✭✭✭
    Options

    Hello @AaronM - I just checked my sheets (in workspace, and in sheets) and I can insert the latest comments column. Also if one already exists - I see "Manage" last comments column with the ability to disconnect it. So if you had that column already present in the sheet - you should see the manage option. Sorry I could not assist with a solution for you, but a little more info my help troubleshooting process.

  • AaronM
    AaronM ✭✭✭
    Options

    Thank you, all for your input.

    The discovery is that you cannot make an existing column a "Latest Comment" column. The only way to assign that property to a column is during the initial column add/creation. If a group of 4 or 5 columns is added and then you try to select one of them and change the property to "Latest Comment" that option will be greyed out. If a new sheet is created and there are 6 existing columns with a new sheet... none of those can be the latest comment. That setting has to be done during the initial add/insertion/creation of that column..... (which is the new winner of the oddest programming logic, ever)

    Here is SmartSheets rationale/guidance

    "Be informed that, by design, the Latest Comment column can be selected when inserting a new column; however, this column type is not available to be changed for an existing column.

    Due to how this connection works with the Conversations panel, if you decide to delete the Latest Comment column and then add it back at some point later on, this connection also needs to be removed either by refreshing the sheet or through the Conversations panel."