Workflow automated email notifications

Options

I have a sheet that has several automated workflows where when something changes an email is sent to a contact in a cell.

This has been working absolutely fine until yesterday with proper formatted alerts being sent to the correct people with the relavant attachments. The emails were set in vertical format with all information neatly layed out and easy to read.

Since yesterday these automated workflow emails have chenged to horizontal format and no attachments are included.

Has something changed? I have tried recreating the workflow several times but with no success.

Images shown below with the top image being correct and the bottom image showing how the emails are appearing now.

Any help or ideas how to resolve this welcome

Murray Soutar

Answers

  • Brian_Richardson
    Brian_Richardson Overachievers
    Options

    Hmmm I thought they stopped doing that. In the past that "table" layout was used when there were multiple simultaneous "hits" on the automation going to the same user. ie Smartsheet thinks that there's multiple Car Allowances to send at once.

    However, there's only 1 row on your table so I'm not sure that's the reason. Almost seems like some piece of older code got rolled back in?

    I'd probably send this on to Support for investigation, particularly if it ends up being not a one-time thing.

    BRIAN RICHARDSON | PMO TOOLS AND RESOURCES | HE|HIM

    SEATTLE WA, USA

    IRON MOUNTAIN

  • Will Jeffords
    Will Jeffords ✭✭✭✭✭✭
    Options

    hi @CRL Planning , could you screenshot the automation config for us to help you diagnose the issues here? Interesting use case!

    Best,

    Will

  • CRL Planning
    Options

    Guys

    Thanks for your help here, this is a strange on as I have many workflow automations but it is only this sheet that is acting like this.

    As you mentioned you sometimes get caught out with workflow emails where a couple of entries come in together and I understand that this will create a landscape table to accommodate the multiple entries. This is not the case here as this is a fairly new sheet and doesn't have many entries and it was delivering the correct format of notification until earlier this week.

    The workflow config is fairly simple and I have attached a copy of it as requested. The workflow normally has several other email addresses in the distribution but I have removed these until I can troubleshoot this issue.

    Regards

    Murray Soutar

  • CRL Planning
    Options

    All

    I have been carrying out some further testing on this issue and I have found that if you allow the automation to run as designed by selecting the check box, then it runs fine and the email is delivered in the correct format.

    When testing this I am using the "run now" command from the automation page on the required row and when you do this the email is delivered in horizontal format.

    From this it appears that the workflow is working properly but you just can't use the "run now" to check the output as it will not run correctly even though a single row is selected for the automation to run on.

    Murray Soutar

  • Brian_Richardson
    Brian_Richardson Overachievers
    Options

    Nice catch I’d definitely follow up with support on this so a dev can address this bug.

    BRIAN RICHARDSON | PMO TOOLS AND RESOURCES | HE|HIM

    SEATTLE WA, USA

    IRON MOUNTAIN

  • SWahbeh2_10
    edited 06/03/24
    Options

    Is there a way to pull column info into the automated responses so they are different in each email sent out for integrated system tasks? Change the customized message so it isn't identical each time. Would the bracketing {{CUSTOM INFO HERE}} suffice?

  • Brian_Richardson
    Brian_Richardson Overachievers
    Options

    Seems like a good way to do it, yes.

    BRIAN RICHARDSON | PMO TOOLS AND RESOURCES | HE|HIM

    SEATTLE WA, USA

    IRON MOUNTAIN