Automation not working

Options

Hello,

I've created a form and setup different automated workflows. When the form is submitted, and a new row is added, I have a notification going out to someone's email. This is working fine. The next step is not working. When someone at the sheet level changes a dropdown from blank to 'pending', I want a notification to go out to a separate email address. The automation trigger is when rows are added and when 'Type of Request' is 'X', with a condition of 'Request Reviewed Status' is one of 'Pending', then send a notification.

Is the order incorrect or condition incorrect? Thanks for your advice!

Answers

  • bisaacs
    bisaacs ✭✭✭✭✭
    Options

    Hey @Nathan Umbriac,

    Is this all in one workflow or split out? If it's not split, you'll want to do that. You'd then want the automation trigger for the 2nd email to be "When rows are changed" rather than "When rows are added".

    Hope this helps!

    If my response was helpful in any way (or answered your question) please be sure to upvote it, mark it as awesome, or mark it as the accepted answer!

    I'm always looking to connect with other industry professionals, feel free to connect with me on LinkedIn as well!

  • Nathan Umbriac
    Nathan Umbriac ✭✭✭✭✭
    Options

    Thank you, @bisaacs

    I do have all of the workflows split out. The completed workflow is working, but the pending workflow is not.

    Any additional insights?

  • bisaacs
    bisaacs ✭✭✭✭✭
    Options

    Hey @Nathan Umbriac,

    Can you provide a screenshot of the workflow that's not working?

    If my response was helpful in any way (or answered your question) please be sure to upvote it, mark it as awesome, or mark it as the accepted answer!

    I'm always looking to connect with other industry professionals, feel free to connect with me on LinkedIn as well!