Elapsed time - 24hr workday - Display bug?

See the attached pic.   

  • The sheet is set for 24hr workdays.  Mon-Fri.   
  • There are 2 tasks.   one with duration 7d  and one with duration e7d.
  • The e7d  task does not display 7 days of working.  The gantt chart bar does not show sunday as a working day.
  • Resource view DOES show sunday as a working day.


Also, the "roll-up" on the resource view shows some days at 200% and some days at 100%... which is correct, but the rollup is shifted 1 day out of position.  It doesn't agree with the detail numbers underneath.







  • Shaine Greenwood
    Shaine Greenwood Employee
    edited 07/03/18

    Hi David,

    The resource view display problem may be browser based. Try opening the resource view in another browse to see if you get the same issue.

    As for the Gantt, make sure that on the sheet level, you've removed all non-working days. You can change these settings on the sheet level by right-clicking a Column Header and selecting Edit Project Settings.

    If you continue to get the same issues, please reach out to our Support team to troubleshoot further.

  • I have this same problem and unfortunately I think Shaine's response is missing the problem:

    Using 'e' before a duration is supposed to show elapsed time irrespective of working days. It appears to do this correctly in all views except the Gantt. On the Gantt the bar does not cover the final day. So in David's example above he has a e7d task that only covers 6 days in the Gantt.

    Is this a bug? Operationally for us it will make using elapsed time incredibly error prone.

  • Here's an example. I need to track sporting events in our project plans. Tour de France finishes on Sunday, but you can see the Gantt bar stops at the end of Saturday.

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!