Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Template is bringing in unwanted columns

Megan Marques
edited 12/09/19 in Archived 2015 Posts

I created a sheet in a specific format to be used over and over again. I made it a template.

The problem is that when I use the template to make a new sheet it brings in 43 additional (and empty) columns to the right of my data. This becomes and issue when I try to print the sheet and I have to remove them all to get the sheet to fit one page wide. I tried remaking the template and confirmed there are no extra columns there when I did so, but the still come into any new sheets based off the template. Why is this?

Thanks!

Tags:

Comments

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭

    Megan,

     

    Do you perhaps mean 43 additional ROWS? (Rows are horizontal, columns are vertical). 

    If have never seen additional columns added and just tested that no new bug or feature had been added since I last used a template. Looks OK.

    However, I believe new sheets created from templates have a minimum of 50 rows.

    If your template has 7 rows, 43 will be added.

     

    I don't know of a way to turn this off.

    Two quick options to enable your printing:

    1. Delete the unneeded rows. Select all the rows and then use the Row Menu of any selected row to access the "Delete Rows" menu item.

    2. Add a checkbox column with the non-empty rows in your template checked.

    When you create the new sheet from the template, filter on the checkbox column.

    Only what is filtered will be printed.

     

    Hope this helps.


    Craig

  • Megan Marques
    edited 12/12/15

    HI Craig,

    Thanks. I do mean columns. As far as the extra rows go the way I deal with that is just by highlighting my data and printing on the selection. However, the columns have to be deleted 5 at a time prior to being able to print the sheet.

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭

    Megan,

     

    I have never seen that.

    Perhaps an email to [email protected] or someone can chime in that has seen that behavior.

     

    Apologies that I was not able to help.

     

    Craig

     

  • Jaye Casciano
    Jaye Casciano ✭✭✭✭✭✭

    Hi Megan, this is one of those annoying "have you tried turning the computer off and on?" type questions...but have you made sure there are no hidden columns giving you this grief? Right click on any column head > Unhide All Columns. Thought I'd throw it out there just in case, although I'm not sure you'd have taken the time to hide 43 columns Wink

  • Travis
    Travis Employee

    Megan, I agree with Jaye. There may be hidden columns in your template that are unhidden when you create sheets from the template. 

     

    Try this:

    -Create a new sheet from the template

    -Right click on a column header and select Unhide All Columns

    -Delete any extra columns

    -Save the sheet as a template (name is something new, to identify it as the new template)

    -Create a sheet with the new template (confirm you are using the new template and not the old one)

     

    If you are still seeing the extra columns, email the Support team and they can help troubleshoot further: [email protected]

     

    Let us know what the issue was! Smile

  • I appreciate your candidness and the thought did occur to me that I may have missed that but upon right - clicking on a column header I seem to have no option for "Unhide all columns". Does that mean all of the columns are open?

    Unhide Smartsheet.JPG

  • by the way it was very odd but when I went to go make a sheet again from the template to make sure all columns were visable there were actually way more columns now than there seemed to be before. It felt like deleting them 5 at a time took forever. ?

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭

    Megan, 

     

    To answer your previous question on no option for "Unhide all columns".

    Does that mean all of the columns are open? 

     

    Yes, that is what it means. From your screenshot, there are also no visual cues that there are hidden columns. I assume Support will have to solve this.

     

    Can you send a screenshot of the Template Preview pane?

    I am very curious on what is causing this.

     

    Craig 

     

  • Travis
    Travis Employee

    This is not something I have seen before and would love to take a look at your template. Would you mind sharing your template with me so I can troubleshoot?

     

    You can share a template by creating a new workspace, drag the template into the workspace, then share the workspace.

     

    My email address is [email protected]

     

    Thanks! 

This discussion has been closed.