Welcome to the Smartsheet Forum Archives

The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Restore from local backup?

edited 12/09/19 in Archived 2016 Posts


I'm wondering how I can restore all my users sheets and workspaces from a local backup done with the smartsheet backup tool?


Do I need to copy and paste everything ? Cause I tried to import the xls files and got an error that the "xls" file isn't a valid xls file which is confusing since I use the latest backup tool 1.6.0 to backup the sheets. I setup this trial account to test if the restore process works smoothly.




  • Richard Rymill SBP
    Richard Rymill SBP ✭✭✭✭✭✭

    The XLs files should import easily and definitely dont need to Copy Paste, too risky!. 

    Have a closer look at your Xls files and see why they are "Faulty"? 

    We have never experienced what you describe, neither have our clients. 

    Good luck. 


  • kjh
    edited 04/23/16

    I have now tried to make the backup with the backup tool on two different computers. 

    I still can't import the files as I get the following message when trying to import via "Import Excel File" 

    Message: "An error occured while importing your file. Please ensure that the file you are attempting to upload is a valid Excel file (.xls, .xlsx) , Comma Separated Values (.csv) or MS Project File (.mpp, .xml)"


    So how can I solve this? I really need the backup to be a proper backup, and since I tried to make the backup to two different computers I'm sure that the harddrive wasn't the case which I first though.

  • Travis
    Travis Employee
    edited 04/25/16

    Hi kjh, I looked up your account and I see the errors you are getting but I am not familiar with the particular error. 


    I see you emailed the Support team last week and the Support rep asked for the Excel file that is producing the error. To further troubleshoot this, please reply to the email that was sent to you, with the Excel file producing the error and they will assist further.



  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭

    I have $5 on special characters in sheet names as the reason.



  • kjh
    edited 04/26/16

    I emailed support now with one of the files.


    I tried to make a backup from the account through "request backup" and then downloaded the backup archive. I could restore the files without any problem.

    The files in the archive had the extension "xlsx", while the files from the backup tool has "xls" extension and I'm not able to import any of those files done with the backup tool..

  • Travis
    Travis Employee

    Have you tried changing the file format from xls to xlsx then import it?

  • Just tried and it worked. I then have to rename like 100 files before doin a restore.

    So there is something wrong with the backup-tool then i assume?


  • kjh
    edited 04/27/16

    I also wonder if there is anyway to restore all accounts without having to restore each file individually? Which takes a lot of time.

  • And how does one restore with the backed up attachments?

  • Travis
    Travis Employee

    kjh, I looked into the thread you have open with our Support team and I see the rep has escalated this issue to our Operations team as this is not normal behavior or something we have heard from other users. 


    There is not a bulk import feature. Out of curiosity, why are you trying to import 100 backed up files at a time? Did you have data accidentally deleted on 100 of your sheets?


    Attachments are not imported with the Excel file - attachments will need to be uploaded manually. 

This discussion has been closed.