Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

SIGHTS - Error: "Source report missing" in Report widget?

Dietrich KochDietrich Koch ✭✭✭✭✭
edited 12/09/19 in Archived 2016 Posts
05/18/16 Edited 12/09/19

In a Sight there is a section where a project plan is shown via report widget. Source is a report based on a project plan. It worked well until today...

 

All of a sudden the plan in the Sight is gone, although the source report is still available and showing content correctly.

 

Since I had no idea for the cause, I tried to set up a new report widget, clicked "Add widget" > chose report widget and selected the corresponding report. After some seconds the widget came up blank and instead of a title its says: Source report is missing! ("Fehlender Quellbericht" in german language).

 

Did anyone ran into the same effects and identified a cause?

Maybe some kind of wrong content or error in the report itself that the Sight widget can not handle?

 

Best

Dietrich

 

 

BTW:
The Sight itself works in other workspaces... 

Comments

  • Chuck MuirheadChuck Muirhead ✭✭✭✭✭

    My reports are appearing correclty on all of my sights

  • Hi Dietrich,

    Here's some info about how report widgets display content, for context:

    - The report widget shows data using the permissions of the person who added the report widget.

    - For the report widget to continue to display content on the Sight, the person who added the report must continue to be an admin on both the Sight and the report.

     

    That said, I have a couple of follow-up questions for you:

    - Are you able to view data on this report if you open the report directly?

    - Are you able to insert a report widget based on this report in a *different* Sight?

     

    Thanks,
    Daniel

     

     

  • Dietrich KochDietrich Koch ✭✭✭✭✭

    Hi Daniel,

     

    I'm admin on workspace-level, so - yes on both the Sight and the report

     

    Are you able to view data on this report if you open the report directly?

    Yes, I can open the report and see all data

     

    Are you able to insert a report widget based on this report in a *different* Sight?

    I set up a new workspace for testing. After tha I copied (save as new) 

    - the project plan

    - the report

    - the Sight

    into it and updated the links/references accordingly.

     

    The "old" widget still shows "no source report".

    BUT: I tried to insert the same report via report widget again and now it worked! Both widgets are based on the same report...

     

    Looks like it really is a problem with the rights, but as said - I'm admin on the workspace level... I'm not the owner of the sheet/report/dashboard.

     

    Any idea?

    Dietrich

  • Dietrich KochDietrich Koch ✭✭✭✭✭

    As said this does not work in the original workspace...

  • Dietrich KochDietrich Koch ✭✭✭✭✭

    Amendment:

     

    My colleague (owner of the workspace and the corresponding sheets/reports/Sights) also tried to add a new report widget based on the report of the project plan in the Sight and failed with the same response within the Sight...

  • Daniel SteinDaniel Stein Employee
    edited 05/19/16

    Thanks Dietrich for the follow up info. Glad to hear it is working in the new workspace but sorry to hear the original one still isn't working. One other thing that could cause a report widget not to load is if it has a very large amount of data or a Gantt chart spanning a very long period of time.

     

    As a next step you are welcome to contact [email protected] for the technical support team to take a closer look at what is going on. Please include a link to this community thread in the email so that they have the context. 

  • Dietrich KochDietrich Koch ✭✭✭✭✭

    Hi Daniel,

     

    ok, I'll do so.

     

    Load should not be too much, since the plan currently consists of only 147 rows and covers a range of 11 months...

     

    Thanks 

    Dietrich

  • Marc BeaulieuMarc Beaulieu ✭✭✭✭✭

    I am having the same issue and I think it is related to the new function they added today. You can now add descriptions to the columns. I think that function (If you are on the early release program) has done something... People who are not on this program, their dashboards or sites still work in my company.

  • We are having this same issue today.  Bar Graph on our main Dashboard is not working says "missing source" but when I edit widget and look at the report it previews correctly, graph and all.  Also the report itself is fine.   Just noticed this not working today.  

  • Mary_AMary_A ✭✭✭✭✭

    We are having this issue on our Dashboards. 

    • We have used CURRENT_USER in the underlying reports. 
    • We have set Dashboard viewer option on the widget
    • Our users have viewer on the dashboard

    NOTE: Our users sign in with Google --- not via SSO/SAML but be belonging to an authenticated domain

This discussion has been closed.