Welcome to the Smartsheet Forum Archives

The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Error in creating new Smartsheet from Google Drive

edited 12/09/19 in Archived 2016 Posts

Anyone see this or know how to get around this? I could not find anything related to this problem.


I have successfully installed the Smartsheet app to Chrome from the Chrome Web Store. I do New->More->Smartsheet. I get past the "Your domain administrator has approved access to Smartsheet" .

Then, I see the error message,


"Sorry - the Google Drive action you have performed does not appear to be valid.      Smartsheet.com"


I'm using Chrome v51.0.2704.103 m on a Win7 computer.


  • Kennedy Stomps

    Hi FeliciaLabs-- I haven't encountered this error before! Can you email our Support team at Support@Smartsheet.com and include a screen capture of this error message, as well as a link to this post (or a copy of the information above). Please also include any other troubleshooting steps you may have tried in the meantime. Let me know if you don't hear from someone shortly and I'll be happy to follow up on your behalf :)

  • FeliciaLabs

    So, the issue is resolved. For our organization, if you keep trying multiple times (2 or more), you eventually get to the "Share data with app" screen. Then, we can create the new Smartsheet sheet. I think it happens only on the very first attempt. Maybe it's an authentication issue?

  • Kennedy Stomps

    Hi Felicia-- Glad to hear it worked eventually! It might be that Drive is trying to authenticate and that is causing a delay. Let me know if you run into further issues with this and I'll be happy to help troubleshoot further :)

This discussion has been closed.