Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Blank cell in auto numbering

Options

How do I remove auto numbering from one cell in a column so it is blank and numbering continues in next row?

Comments

  • Jason
    Jason Employee
    Options

    Auto numbering will only take effect on empty cells. You can change the column type to Text/Number and enter some text value in a cell and change the type back to Auto-Number. The text you entered will persist. You could enter a small character, such as a hyphen or underscore into the cell and it won't be overwritten; it can't be blank though or a new auto number will be applied. The caveat is you have to be a sheet admin to change column types.  

  • Linda McDonald
    Options

    Thank you.  I tried that and it worked.  However, now I'm having trouble getting the auto numbering to work at all.  I'm following the instructions, saving but the auto numbering doesn't appear in my worksheet.  What can I be doing wrong? 

  • Jason
    Jason Employee
    Options

    Hmm. The only reason why the auto numbering wouldn't take affect is if the cell is non blank, or the column is not an auto number Type column. The case where the cell is non blank is what we're using to "remove" the auto number from cell, but the column still needs to be an auto number Type column. 

     

    I'll outline the steps so it is a little more clear. 

     

    1. Right click on your auto number column and select 'edit column properties' 

    2. Select Text/Number and click OK. (this turns the column into a basic text column allowing you to make changes to the data in the column)

    3. In the cells that you want to remove the auto numbering, enter a small character such as - or _  don't use a single apostrophe ' as that won't work for this case. The key is the cell can't be blank or empty. 

    4. Once you have made your changes to the data in the column, right click the column and select 'edit column properties' and change the Type back to Auto-Number, click OK. 

    5. Save. 

    6. Any new rows will should have auto numbering applied to them from here on out. 

     

    The end result would look something like this: 

     

    Capture.JPG

  • Linda McDonald
    Options

    THank you Jason.  I've managed to take out auto numbering from some of the cells.  However, I still can't get auto numbering to work despite seemingly following the steps.  It did work once for some reason, but the numbering started at 6 rather than 1 which isn't much help. The column certainly seems to be an autonumbering column and my Edit Column Properties looks like the screen above.  I'm not sure how I make the cell "non blank".  In the text/number selection I've hit delete for all the cells in that column where I want auto numbering to work.  Perhaps you can explain this a bit more.   I'm spending a lot of time on this and its getting very frustrating!  Thanks.

    Linda McDonald

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭
    Options

    Linda, 

     

    Did this ever get resolved?

     

    Craig

This discussion has been closed.