Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Copy and Paste doesn't work!

07/28/16 Edited 12/09/19

I am trying to copy and paste individual cells, or rows, but while it 'copies' (either by right click or cntrl C), paste is greyed out.

 

What am I doing wrong?!

Previous1

Comments

  • Heidi DeckerHeidi Decker ✭✭✭✭✭

    Hi Rachael,

    Here is information that might help you.

    Using Copy & Paste

    Use copy and paste to easily replicate data in your sheets, or between Smartsheet and another program.
    • Use either the right-click menu, or the keyboard shortcuts [Ctrl] + [C] to Copy, and [Ctrl] + [V] to Paste rows, cells, formulas, hyperlinks, and hierarchy within Smartsheet. Mac users should use [Cmd] in place of [Ctrl] unless otherwise noted.
    • Only use the keyboard shortcuts to copy and paste data between Smartsheet and other programs, such as Excel – the right click menu doesn’t always function as expected between different applications.
      TIP: If you've copied a multi-line cell in Excel or other program, double-click on the cell in Smartsheet before pasting it in to prevent the lines from spilling over into the cells below.
    • Use the Paste Special feature to help when creating cell links, or when you need to copy formula results or formatting to a different cell.
    • The drag-fill method can be used to quickly copy a value, or formula, from one cell and paste it into numerous adjacent cells.
    • Hope this helps,
    • Peace!
  • J. Craig WilliamsJ. Craig Williams Top Contributor

    I've been having problems with copy/paste recently too.

    Can't consistently copy and paste between OpenOffice Calc and UltraEdit but not between Calc and Smartsheet, for example.

    Driving me nuts (too late)

     

    Craig

  • Same issue here on Mac OS Sierra... using Safari.. cant copy paste. However it works in Chrome.... The copy paste if you select the content in the cell works in safari but not the entire cell itself or rows or columns - must be a bug.

  • edited 09/30/16

    YES! COPY AND PASTE ISN'T WORKING IN SAFARI - WORKED LAST WEEK NOW JUST GONE!!!! SMARTSHEET GUYS YOU NEED TO REACH OUT TO APPLE AND GET THIS WORKED OUT!

  • Dana MoodyDana Moody ✭✭✭✭✭

    I am having trouble copying and pasting from excel on a sheet I copied from one I had created, but I deleted the data. I can not even type in data. I have all my columns unrestricted. 

     

  • Hi.  This is a relatively old post but I'm just checking if this was fixed or is planned to be fixed?  I'm having issues pasting into smartsheet when using Safari - I have to switch to Chrome which is painful!

    Seems very bizarre that paste wouldn't work in Safari so I'm wondering if I'm doing something wrong but can't find a solution in Community.

  • Same issue just popped up for me.  I'm using Chrome on Windows 10.

  • Michael HMichael H Employee
    edited 07/30/18

    Copy and Paste from one Smartsheet cell to another only requires you to click the cell once as long as they are in the same browser instance. However, copy and paste from another app or from smartsheet in another browser instance requires double clicking the destination cell.  For example, a url from salesforce, requires you to double click the cell in Smartsheet prior to the paste.  

    Single click destination cell = copy + paste from smartsheet to smartsheet if in same browser instance.

    Double click destination cell = copy + paste from outside smartsheet to smartsheet or smartsheet to smartsheet if they are in different browsers.

     

    Hope this helps :)

  • Mike WildayMike Wilday ✭✭✭✭✭

    Hi Michael, 

    There is an error with smartsheets. I used to be able to copy and paste rows from one sheet into another (I am using the latest version of Chrome). But since sometime last week I can no longer copy and paste between sheets. All formulas, hierarchy, and data is removed. I am using the CMD+C and CMD+V to copy and paste rows. 

    When I copy several rows, then select a row to paste them into, It won't paste. And the right-click menu doesn't show paste either. 

    Steps to test. 

    1. Open a sheet with several rows of data using formulas and indented rows.
    2. Copy a set of those rows including the parent rows by clicking the first row and then holding shift and clicking the last row (I did this with 12-15 rows of data).
    3. Press cmd+c to copy the rows (indicated by the marching ants outline)
    4. Navigate to the new sheet (or have it open in a separate browser window - both fail)
    5. Click on the row indicator where you want to paste the rows 
    6. Press Cmd+V. (nothing happens)
    7. Right Click - look for paste (its not highlighted).
    8. Click on the first cell in that row. 
    9. Paste the data (it pastes without formulas and without formatting or hierarchy.)

    HELP! 

     

  • Michael HMichael H Employee

    Try double clicking the desired location for the paste, not single click.  If that doesn't solve, then I would submit a support ticket if this was working prior and now isn't.  I also recommend inquiring into pro-support with your Smartsheet acct manager as well.  It just launched in April and gives phone support among other things.  Good luck!

  • Try reloading your sheet.

     

    I had this same frustrating issue, Ctrl+C/Ctrl+V wasnt doing anything. After refreshing sheet seemed to work fine again.

  • I am having this same issue right now, trying to paste a formula from one cell to another. 

    Paste is grayed out... this is ridiculous; Chrome on Windows 10.

  • Any update Smartsheet?  This is still not working it seems.  Fundamental functionality broken

  • Is there an update to this issue?  This has just started happening in the last few weeks.  I can copy SS content, but when pasting outside of SS, (WORD, email, etc.) it only pastes as plain text.  I am using CTRL+C / V

  • echaikaechaika
    edited 02/22/19

    Same problem here, never had a problem before but all of a sudden I can't paste into a Smartsheet cell. 

    I can paste something into an email, or Excel document, etc, so I know it's copied to the clipboard, but ctrl+v doesn't work anymore in Smartsheet, whether I click into a cell once or double click. I've refreshed the sheet, restarted the computer, tried in both Chrome and Firefox, nothing has worked.

    Interestingly, my colleague is NOT having this problem on the same sheet. 

This discussion has been closed.