Form Submission Issues

edited 12/09/19 in Using Smartsheet
11/14/19 Edited 12/09/19

Hello!

I have a Smartsheet that I use to track multiple data entries each day from our vendor agents. I created a form for them to fill out for each instance, and they typically have no problem adding the data to my Smartsheet. 

Recently, when the agents try to submit a form, if they select the "Send me a copy of my response" checkbox, it won't allow them to submit the form. If they leave that box unchecked, it will still allow them to submit the form. 

Do you know why it would make a difference if the user chooses to have a copy of their response emailed to them? Or why this is stopping them from submitting the form at all?

Thank you in advance!

Tags:

Comments

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Hi,

    Do they fill in their email address?

    I hope that helps!

    Have a fantastic day!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    work-bold

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Hi Andree! 

    Yes, they check the box asking for a copy of their responses, and then fill in their email address and it won't let them click on the "submit" button to send the form.

    Thank you!

    -Erica

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Happy to help!

    Are there any required fields that aren't filled out?

    I'd be happy to take a look!

    Can you maybe share the form, sheet(s), or some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])


     

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Tomer BlankitnyTomer Blankitny ✭✭✭✭✭

    I encountered the same problem.

    If you find a solution please share it.

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Hi Tomer,

    Can you describe your process in more detail and maybe share the sheet(s)/copies of the sheet(s) or some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    I hope that helps!

    Have a fantastic weekend & Happy Holidays!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Hello


    I have a similar issue, our vendors are submitting deviation request through Smartsheet form but one of the vendor is unable to submit (nothing happens when the submit button is clicked)


    -         All the mandatory fields are filled and no error message

    -         Documents attached

    -         E-mail entered and “Send me a Copy of my Responses” is selected

    -         Microsoft Edge browser is used

    Screenshot attached

    Would appreciate your help with this !

  • David NgDavid Ng ✭✭✭✭

    I am facing the same issue but not with every user. Unable to replicate consistently.

  • Has anyone been able to figure this out. I have a similar problem where the user completes the form, clicks submit and gets an error message that the form can't be submitted.

    Would be great if we could get to the bottom of this!

  • I just had this exact issue last week on a form connected to a highly protected sheet that none of our users have access to view, though I would love to have them be able to get a copy of their own responses to the form submission. For now, I have disabled the ability to send a copy of their responses so we do not encounter this in the meantime as I can pull the data out of the sheet if necessary.

    For reference, this particular user was in China and we have somewhat inconsistent access in China but the main issue seemed to be the checkbox for email. She was not getting any error messages, she had filled out all the required fields, was using Microsoft Edge, and had filled out her email address. She simply was not allowed to click on the Submit button at all.

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Hi @Fakir Mohideen, @David Ng, @Deborah Force & @H Brian

    I hope you're well and safe!

    I think it could have something to do with the ReCaptcha and that it somehow doesn't show.

    You could automate it instead and send them a copy by adding a Workflow combined with an Alert as a possible workaround.

    Would that work/help?

    I hope that helps!

    Have a fantastic week & Happy New Year!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

Sign In or Register to comment.