Automation Not Working

02/26/20
Answered - Pending Review

I have an automation that when an item is marked as Rejected it should be moved to a different sheet (see below)... The issue is that this automation is not working and items are not being moved to the Rejected sheet.

Any ideas why??? This is a pretty straight forward automation but wondering if the other columns (assigned to, Overall Status) are having anything to do with this hapenning??



Answers

  • Make sure that all the columns that exist in the first sheet exist in the second sheet. If there are columns in the first that aren't in the second sheet, and you don't have Admin or Owner access to the second sheet, the move will fail. This is because the system will try to create the missing column in the second sheet.

    Regards,

    Jeff Reisman, IT Business Analyst & Project Coordinator

    Mitsubishi Electric Trane US

  • @JReisman27 Thanks for the input.


    There are columns in the first sheet that don't exist in the second, however I am an Admin to the sheet...


  • Andrée StaråAndrée Starå ✭✭✭✭✭
    edited 02/26/20

    Hi,

    @srangel

    To make sure that it will work, you could try copying one row to the other sheet so that the columns are already there.

    Also, make sure that these conditions are met.

    Would that work?

    I hope that helps!

    Have a fantastic week!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    ✅Did my post help answer your question or solve your problem? Please help the Community by marking it as the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • @Andrée Starå

    All conditions are met, weird thing is this automation was working before. In any case, l was not able to copy the one row from the original sheet to the destination sheet, whenever l saved/refreshed the page said row was going back to the origin sheet. We decided to trash the destination sheet and create a new fresh one and it works.

    Still curious as of why it was not working....


    Thanks!

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    @srangel

    Strange! Glad you got it working!

    I'm also curious. If you haven’t already, I would recommend that you reach out to the Smartsheet Support Team.

    Let me know what you find out, if anything!

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

Sign In or Register to comment.