Email notifications working... some of the time

Hi There,


I have a number a approval workflows set up and only some are sending email notifications. I am trailing it between my smartsheet email account address and a seperate personal one.


Workflow 1: When a row is added via a webform it triggers an approval to a specific email address (my non smarthsheet account email).

I get the notification email just fine and can choose to either approve or decline. If I decline it is supposed to change the row status from "New" to "Revisit". When status changes to "Revisit" it triggers...


Workflow 2: When a row is added or changed and status changes to "revisit", send an approval request to a contact in a cell (my own smartsheet user contact in a submitted by field).

This should (and I have it working on other automations in the sheet) send an email to my smartsheet linked email account... but I get nothing. I do get a notification in smartsheet, so I can go in there and add a comment and approve (changed text to "submit for update" in mine). This leads to a third workflow...


Workflow 3: When a row is added or changed and status changes to "Review", send an approval request to a specific email address (again my non smartsheet linked email).


Again, I get this approval request no problem. If this approval request is rejected it is supposed to send a final alert email to the same contact in the submitted by field. And again I only get the notification in smartsheet not in my email.


I have made sure all notifications are turned on, even those for ones I have submitted. I even tried changing the notification from a person in a cell to a specific email address to no avail. If I switch it and send the ones that are working to my smartsheet linked email and the ones that are not working to my non smartsheet linked email... it still works fine. Last when I do submit the approvals via smartsheet rather than via the emails... I still get update confirmations in my email.


Cheers,

Daryl

Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi Daryl,

    Strange!

    First, make sure that you have allowed yourself to receive notifications properly in your Personal Settings (circle/profile in the upper right corner) and secondly check the Permission setting for the Automations. (cog in the top right corner in the Automation overview)

    If that wasn't the issue.

    Can you maybe share some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, andree@getdone.se)

    I hope that helps!

    Be safe and have a fantastic weekend!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please help the Community by marking it as the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:andree@workbold.com | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • I have all of my a notifications turned on and everything set to unrestricted.


    This is the one that works.

    And when it is declined it changes a status which triggers this one:

    I do get the notification but not as an email.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    @Daryl Peereboom

    Strange!

    How did it go? Are you still having the same issue?

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:andree@workbold.com | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hey @Daryl Peereboom!

    If you are receiving the notification within Smartsheet (in the notification center or bell icon), this indicates that the workflow is set up correctly and working as expected, which means that the issue is likely related to your email settings instead.

    Based on your description it sounds like your Smartsheet work email is the address not receiving the notifications, is this correct? If so, please check your spam/junk folder to see if the automations have been routed there. Our Help Center article on not receiving emails (click here) has a few relays that you can add to your Trusted Senders list so this doesn't happen in the future.

    Let me know if this helps!

    Cheers,

    Genevieve