Move or copy row workflow results in empty rows in destination sheet

Options

I have set up a few workflows that copy rows from an interim calculation sheet into a destination sheet for history/time series purposes.

Whenever I set this up, I run a few test cases to make sure it working okay before I let the scheduled workflow take care of this automatically. This means, I have a few test rows that I need to delete manually when I put the sheets and the workflow 'live'.

Unfortunately, once I remove the test rows and the copying is done automatically, the new row is not showing up directly under the latest row, but a few rows further down, i.e. it leaves a few empty rows in the destination sheet which then results in formulas not being auto-filled in the new row. This then ripples through all the way from the sheets via the reports to the dashboards.

Any hints on how to avoid this?


Note:

This issue eventually disappears but I've had a few going wrong for several weeks before this rectified itself.

It also happens with 'Move Row' workflows, not just when copying.

Answers

  • RossL
    RossL ✭✭✭✭✭✭
    edited 06/24/20
    Options

    @Werner Gerstacker

    when you run the test cases are you deleting the row by selecting then right click and delete? Or are you just deleting the data in the cells? if you do not delete the whole row it will keep that as an active row and any new information will be added under it.

  • Werner Gerstacker
    Werner Gerstacker ✭✭✭✭✭
    Options

    Thanks @RossL - I am deleting the whole row during my cleanup and it properly moves the other already filled rows up correctly.

  • Werner Gerstacker
    Werner Gerstacker ✭✭✭✭✭
    Options

    @RossL - your question triggered an idea, though.

    I have deleted all empty rows below the last exiting row now and hoe that this might resolve the issue - if Smartsheet doesn't have any other option than to add a new row right below the last, current one, maybe it will not add more empty lines.

    I'll post my experience/result once the workflow has triggered the 'copy row' again.

  • RossL
    RossL ✭✭✭✭✭✭
    Options

    @Werner Gerstacker

    That should fix your problem. Make sure to drag you formulas down to the last row and not any farther. There is not need to drag any formulas past the last row I know that was a mistake I made a lot when making the switch from excel to Smartsheet.

  • Werner Gerstacker
    Werner Gerstacker ✭✭✭✭✭
    Options

    🤞 - still puzzled why this would happen in the first place.

    The last row should be the last row, no matter how many empty rows are below 😮

  • RossL
    RossL ✭✭✭✭✭✭
    Options

    It is the way smart sheet is set up. The last row for the automated moves or even forms adding lines will go below the last row that has ever had anything in any of the cells. I know I like to try out formulas sometimes in the empty lines at the bottom of my sheet and I will forget to delete the row and only delete the information in the one cell then and end up with broken formula chains because the next enter will end up 5 rows down from the bottom. if you want to check to see if the row you are expecting to have populate with a move or copy you can right click on the row and check to see if the properties menu is lit up. if it is then that row is active and automated row will end up below it. if its grayed out then it will be the next row that will populate with a move, copy or web form entry.

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!