Workflow only showing column headers not data

Workflow only showing column headers not data

I have an invoice that has 2 levels of approval on it but when I get a test email from the workflow I see that it only has the the column headers on it but no way to see the actual data without going out of the view request and into the sheet. Not understanding the intent of the automated email if when you click View Request it does not take you to the sheet itself to actually see the data. Did I miss enabling something when I created the workflow?

Answers

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Hi @Pamela Wagner

    Can you maybe share some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    I hope that helps!

    Be safe and have a fantastic week!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please help the Community by marking it as the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

  • Here is a screen shot:

    What you see above (Description, Helper, Quantity, etc.) are all of the columns:

    What you see above are the column headers so they aren't seeing the actual data. You can see at the top, which is coming from the notification email, where I put a link to the actual sheet but this makes them connect to the sheet, review the data then come to the notification email, click View Request, scroll to the bottom and Approve or Reject. Seems real clunky to have to go in and out so I suspect that I did not set up the workflow well.

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    @Pamela Wagner

    I'd be happy to take a quick look.

    Can you maybe share the sheet(s)/copies of the sheet(s)? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

  • Not sure in what version this was added, but as of 2019.3, this is easily do-able with regular 'Output Data' tool options:

    Select the 'Skip Field Names' box in the Output tool (highlighted below).

    If writing to a specific cell or range in an Excel file, enter the cell (or range) into the output filepath. Here I've output a single cell of data from my workflow to C3 of an Excel file.

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    @lewis hamilton

    Your solution is for Excel and not Smartsheet so that it won't work, unfortunately.

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

Sign In or Register to comment.