Welcome to the Smartsheet Forum Archives

The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Percent Complete not adding up

Eric Tinney
edited 12/09/19 in Archived 2017 Posts

I need some help figuring out how to make my "% Complete" column reflect the actual percentage using my "Hours" column and not "SLA" (days). The sample below is clearly incorrect. It should be more like 64% complete.


I'm totally stumped. 



% Sample.JPG


  • Eric,


    I may be incorrect, but I believe % Complete is derived based on days (not hours) and Duration; therefore, you need to have a DURATION column active on the sheet by enabling DEPENDENCIES. 


    Try enabling Duration if you haven't already done so (right click on any column heading, select "Edit Project Settings", click box to enable Dependencies).


    I hope that solves it. 


    The other thing to note is that Duration completely impacts % Complete - I have a plan that has several 1 day tasks - when these tasks are marked 100% complete it does not impact the overall % complete unless other tasks with much lnger durations are already 100% complete. Does that make sense? 


    Keep us posted!




  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭



    If your SLA column is the Duration column renamed, then 19% appears to be correct.


    There are 3 tasks under Phase I - Field Notification

    1. General Information Bulletin (2d)

    2. Smartsheet (1d)

    3. Testing (13d)


    The first two are complete, the last is at 0% 

    3d/16d=  18.75%


    Smartsheet's % Complete rollup ignores Allocation %.



This discussion has been closed.