Form response is skipping rows on the sheet

Options

Hi there, I have a form that was created from an issues tracking sheet but when the form is submitted, it's entering the information several rows below the next available row. The sheet is set up to auto-generate the Row ID. Does anyone know why this might be happening?

thank you!

Tags:

Best Answers

  • Mark Cronk
    Mark Cronk ✭✭✭✭✭✭
    Answer ✓
    Options

    Hi @Stacy Maplesden ,

    I've struggled with the same but found that as the sheet gains rows the gap gets smaller. For now, delete the rows between the new record and the last record. As long as your auto number works it's just a formatting issue.

    The other alternative is to have new rows post to the top. You don't get a gap with that.

    Mark


    I'm grateful for your "Vote Up" or "Insightful". Thank you for contributing to the Community.

  • Mark Cronk
    Mark Cronk ✭✭✭✭✭✭
    Answer ✓
    Options

    Hi Stacy,

    It's just personal preference, but to help manage new records I insert a colored row at the bottom of my sheets and label it as "New Records Below" in a text column where it won't impact calculations. It's a visual separator and lets me immediately identify new rows. As part of routine maintenance I cut and paste the new rows above my line and eliminate any blank rows.

    Thanks for contributing to the Community.

    Mark


    I'm grateful for your "Vote Up" or "Insightful". Thank you for contributing to the Community.

Answers

  • Mark Cronk
    Mark Cronk ✭✭✭✭✭✭
    Answer ✓
    Options

    Hi @Stacy Maplesden ,

    I've struggled with the same but found that as the sheet gains rows the gap gets smaller. For now, delete the rows between the new record and the last record. As long as your auto number works it's just a formatting issue.

    The other alternative is to have new rows post to the top. You don't get a gap with that.

    Mark


    I'm grateful for your "Vote Up" or "Insightful". Thank you for contributing to the Community.

  • Stacy Maplesden
    Options

    Interesting. Thanks @Mark Cronk for confirming its not something I did. I wasn't sure if I missed a setting or something else in the form set up. There are quite a few people working the issue sheet so I was hoping there was a solution. Still, it's manageable. Maybe it will be fixed at some point.

    thanks again!

    Stacy

  • Mark Cronk
    Mark Cronk ✭✭✭✭✭✭
    Answer ✓
    Options

    Hi Stacy,

    It's just personal preference, but to help manage new records I insert a colored row at the bottom of my sheets and label it as "New Records Below" in a text column where it won't impact calculations. It's a visual separator and lets me immediately identify new rows. As part of routine maintenance I cut and paste the new rows above my line and eliminate any blank rows.

    Thanks for contributing to the Community.

    Mark


    I'm grateful for your "Vote Up" or "Insightful". Thank you for contributing to the Community.

  • GraesonG
    Options

    I'm having the same issue, but when i check the blank rows properties it stipulates that it was created by a user.

    The user denies doing this, it also shows up on the activity log.

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!