Team members can't see Smartsheet tab in MS Teams

Hello Smartsheet community!

I am pinning tabs in MS Teams to grids and reports in Smartsheet. I can see the tabs just fine and click on them to view project info in Smartsheet. However, none of my team members, how have access to the MS Team and I am sharing the sheet in Smartsheet with them, can see the tab.

Has anyone else experienced this? Any suggestions of how to fix this so my team members can see Smartsheet tabs in MS Teams?

I took a screenshot of what I see (the one with the red circle is the Smartsheet tab) and what one of my team members sees (the one without the red circle because he doesn't have the Smartsheet tab).




  • Hello @Nicole Juba Plant Response ,

    If Sheet is not Published into Teams, or the settings are too restrictive. If you're colleagues are not on the same Email Domain or are not part of your Smartsheet plan, and you Publish settings are set to "Only available to user in the owners account", other users won't be able to view this Sheet.

    To check this, please navigate to your Sheet, and access your Publish Settings to confirm that both "Edit By Anyone" is enabled, as well as "Available to anyone with the link".

    If this does not resolve your issue, you may wish to reach out to the Smartsheet Support Team here:

    Let me know if you have any questions!