Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Epic to story issues from Jira

Lakshmi Patil
edited 12/09/19 in Archived 2017 Posts

Hey all,

 

I recetnly created a workflow with smartsheet and jira. All the issues seem to be imported with the stories under its respective epic indented. Later, when i linked some issues to its epic in jira and then refresh smartsheet i dont see those stories to get automatically indented under its epic. Do i have to do it manually? Is there a solution to it. 

 

Thanks,

Lakshmi 

Comments

  • Hi Lakshmi,

     

    I think I see what's happening.  When a user creates an Issue Link in JIRA, it is just a hyperlink to that issue.  This is great for people, using a browser to find an issue, but it is not a JIRA object in it's self, so Smartsheet for JIRA ignores it.

    To resolve the problem, just go to the issue(s) and assign the Epic Link to the appropriate target.  This will create a JIRA object that Smartsheet for JIRA can see. (see the image)

     

    Have a great day,

     

    Jason

     

    epic link.png

  • I am experiencing a similar issue. I have Smartsheet rows that represent Jira stories/tasks that are not indented underneath their respective epics. In my example (attached), you'll see I've made the link for the story "Contribution Data Dictionary" to the epic "Visualizer GA", but in Smartsheet, they are not connected like I'd expect.

    I did notice that if I open a specific story/task in Jira, edit a field, and then refresh SmartSheet, the story becomes indented under the epic. The link is already there, though, and I'd prefer not to manually "edit" all the tasks and stories under the epics to make them appear the way they should in SmartSheet to begin with. Thoughts?

    SmartSheet Jira Int Bug.png

  • Amoultrie:

    I just added an Epic via Epic Link to a story that didn't previously have one and the Smartsheet for JIRA integration did properly detect that change and indent the corresponding issue appropriately in the sheet. I was using JIRA Cloud for my test. However, I noticed that Atlassian has known bugs for older versions of JIRA where JIRA wouldn't notify listeners such as the Smartsheet for JIRA integration in this circumstance. So if you're on an older version of JIRA it is possible this JIRA issue is impacting you.

    If you just want to bring a sheet back into sync with its corresponding JIRA project, you can always disable the workflow, and then re-enable it, and it should overwrite all of the mapped JIRA values in the sheet, and update the Epic/Story/Subtask indentation to bring all of the rows in the sheet in sync with JIRA. This way you don't need to modify the issues in JIRA to get them in sync again.

    If you continue to see a problem, please report the issue to our Support team with the steps to reproduce and we'll take a another look.

    -- 

    Scott Willeke | Smartsheet

    Senior Product Manager, Automation

    E: [email protected]

    Work Better

    Learn More → smartsheet.com

     

     

  • Scott, that did the trick! Thanks so much for your help on this. I am continually impressed by everyone at Smartsheet for such awesome customer service. Thank you and keep it up!

  • Thank you for the follow-up and kind words. Happy to hear it worked out!

  • brookwarner
    edited 04/04/18

    I'm having this exact issue, and I don't want to have to disable and re-enable the workflow every day to get this to update correctly. 

     

  • Hi, 

    I have just begun using the Smartsheet JIRA connector. I was able to bring all the JIRA issues into the Smartsheet. I am now "formatting" the Smartsheet plan, so that it looks like a proper project plan. 

    I tried to indent some of the task, to give clarity to the stakeholders as to which team these task belong. I observed that on clicking indent button, the Task Name doesn't indent, but instead the "Issue Key" column indents. Refer to the RED circle on the right side in the attached screenshot. 

    I expected the yellow box to indent. This happens if i prepare a project plan, which doesn't use the JIRA Connector. 

    I am starting to work on preparing the plan for a critical project, hence would like to get a workaround or solution to this problem. 

    thanks 

    Robert

    Smartsheet_JIRA.jpg

  • Hi, 

     

    I got the answer, by going through the following article : 

    https://community.smartsheet.com/discussion/there-way-re-designate-primary-column-after-smartsheet-has-been-developed-and-populated

    I found it as a workaround, but hope there is more efficient method to do it.. 

    thanks 

    Robert

  • Robert,

    Glad that you figured it out. In addition to moving the data to/from the primary column with Copy/Paste (as the thread that you linked to suggests) make sure you update the JIRA Workflow's column mapping too! Sorry if that is obvious, but I want to make sure that doesn't come back to bite you.

    Cheers,

    --

    Scott Willeke | Smartsheet

    Director of Product Management, Automation

     

     

     

This discussion has been closed.