Why does calendar view show incorrect date?

Options

When I switch from grid view to calendar view I get May 5194 instead of the current date. I have a sheet with a "from date" and "to date". When I use the previous and next buttons from the calendar view the dates jump around randomly. Any ideas?


Answers

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭
    Options

    Have you ensured that the date in the sheet are correct? Are they being populated as actual dates instead of text strings that just look like dates?

  • Robert Finkley
    edited 04/05/21
    Options

    Thanks for the response Paul, it's appreciated. I've selected the "Restrict to dates only" option on the column properties, so I don't think that's the issue. But the date values are being typed in, so would that override the data type?


    Either way, what's happening is, when I switch to Calendar View, the date the calendar is set to is like May 5194.

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭
    Options

    They should all be dates, but an easy way to check is to insert a temporary helper column (text/number) and apply this column formula:

    =IF(NOT(ISDATE([Date Column Name]@row)), "NOT A DATE")


    Then apply a quick filter to show only rows that have "NOT A DATE" in them. If nothing is displayed when you apply the filter, then it means every row is in fact a date. You can then remove the filter and the temporary column and the sheet will be back the way it was.


    It is odd that it would take you to a date that far in advance. I wonder what is the maximum number of days in the future Smartsheet can calculate. I would be curious to know whether or not that is the date it is taking you to when you switch to calendar view.


    You can also check the data within the dates by doing a quick sort. If you don't want to risk accidentally saving a sort you don't want, you can use the temporary helper column method and use the column formula of

    =YEAR([Date Column Name]@row)


    Then you can see what options you are able to filter on to see if that year number is an option. If it (or any other year number that doesn't belong) appears as a filter option, you can apply the filter, fix the date, then remove the filter and helper column.