Calendar App - Users unable to create new events

Benjamin Brunnette
Benjamin Brunnette ✭✭✭✭
edited 06/14/22 in Add Ons and Integrations

Hi there,

I created a shared calendar for my team using the Calendar App and for some reason, my team is unable to create new events. I've tried the following -

  1. Ensured "allow new event" is checked in the advanced settings of the calendar
  2. Ensured that sharing was "on" and that the emails of those who needed access were in the "allow email/domains" field (FYI - they also have admin status on the sheet the calendar was created)
  3. I used the "Share via link" URL to share the calendar with my team

Still after doing all of this, they are unable to see the little calendar with a "+" in the top right as pictured.

Any help is greatly appreciated!


  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Benjamin Brunnette

    The criteria for being able to see the + to add a new event from the Calendar App is exactly as you've specified above... as long as these users are also shared to the underlying sheet they should be able to create new events.

    I would suggest asking them to log out of all instances of Smartsheet, then log in again to the Calendar App. Please also have them try a different browser.

    If neither of this has worked, please reach out to Smartsheet Support with the source Sheet name/unique ID, a screen capture of your Calendar's Settings (showing the "Allow New Event" is checked), a screen capture of what your collaborators see (without the +), and a list of who these collaborators (emails) are. Support will be able to troubleshoot this with you through a private channel.

    Thank you!