Smartsheet Report not capturing information

Hi all,

I hope you're all well and having a great start to the week! Hoping you can help me, as I'm having issues with Reporting on Smartsheet.

I'm trying to put together a Report that will serve as a "Master Risk Log" for my organisation's project portfolio. I have built the report so that it captures specific information from all Risk Logs in the various project workspaces.

The issue I'm having is that the report is only capturing information from one of the Workspaces, and yet I can see that other Risk Logs meet the criteria I have selected for the data to be pulled into the report.

All Risk logs in the project workspaces are from the same template, and have not had any structural changes made to these. I have also checked the filters I have selected for the report, as well as the spelling on each Risk Log's columns, to ensure there are no discrepancies, but unfortunately I cannot understand why the information isn't coming across.

Any suggestions?

Many thanks in advance and I look forward to hearing from you.

Kind regards,

G. Costa Pinto

Tags:

Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭
    edited 06/14/21

    Hi @Gerhard da Costa Pinto

    I'm well, and I hope you are too!

    Have you updated the report to include the different Workspaces?

    Can you describe your process in more detail and maybe share the sheet(s)/copies of the sheet(s) or some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    I hope that helps!

    Be safe and have a fantastic week!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:[email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Gerhard da Costa Pinto
    edited 06/14/21

    Hi Andrée,

    Thank you for getting back to me so promptly. I selected all Risks logs from the respective workspaces when I put the report together - you will see from the attached screenshot that it is supposedly capturing information from 4 different sheets.

    Also, the rules/filters I put in place are the following:

    1. Status is not Closed;
    2. Residual Level is High or Extreme; and,
    3. Current Escalation is Blank.

    As you can see from the screen shot, this Report is capturing the information from at least one sheet (PR005-05 indicates the sheet in question).

    I have checked all other sheets/ Risk Logs, and these criteria are met in at least two other sheets.

    I hope that's enough information to go on, but happy to try and clarify further if necessary.

    Many thanks once again for your help on this!

    Kind regards,

    G. Costa Pinto

  • Hi all,

    I think I've figured out what the issue is. For some reason, the report is only collecting data from a single sheet for one of the columns I have selected in the report filter.

    In the individual Risk Log sheets, the column in question has been converted to a formula column, and is meant to display the Risk Level (Low, Medium, High, etc.) based on the product of the Residual Likelihood and the Residual Impact. The formula is identical in all sheets:

    =IF([Residual Impact]@row = 0, "", IF([Residual Likelihood]@row * [Residual Impact]@row < 4, "Low", IF(AND([Residual Likelihood]@row * [Residual Impact]@row > 3, [Residual Likelihood]@row * [Residual Impact]@row < 8), "Moderate", IF(AND([Residual Likelihood]@row * [Residual Impact]@row > 7, [Residual Likelihood]@row * [Residual Impact]@row < 15), "High", IF([Residual Likelihood]@row * [Residual Impact]@row > 14, "Extreme", "ERROR")))))

    The column is working properly on all sheets that are informing the report but, depending on which sheet gets selected first, the report will only show data in the column in question for the first sheet selected.

    Is this a problem you have come across? If so, can you advise how to overcome it?

    Kind regards,

    G. Costa Pinto