How to connect to Dynamics 365 using the Smartsheet Connector

Adrian Mandile CHESS
Adrian Mandile CHESS ✭✭✭✭✭
edited 06/14/22 in Add Ons and Integrations

Has anyone had success in connecting Smartsheet with Dynamics 365? I have done what I can on the Azure AD side of things with registering the Smartsheet Connector as an app and adding user permissions. However, when I try to set up the Smartsheet workflow against a sheet, it appears that the Smartsheet side of things is still not able to log into D365 to connect with an ‘entity’ (data table) there. Any ideas what I'm missing?


  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Adrian @ Chess

    The first thing to check is to ensure you have the correct permissions (System Administrator security role in Dynamics 365 and System Admin in Smartsheet. See: Smartsheet for Microsoft Dynamics 365 Connector: Admin Setup)

    If you've followed the steps in the above article, but you're getting a generic error, try removing & recreating the connection:

    • Remove the existing connection
    • Completely log out of Microsoft in all browser tabs
    • Recreate the connection with updated URLs

    You may also want to try this from a different browser to see if this helps resolve the error message. If none of this has worked, I would suggest working with Smartsheet Support directly through a private channel in order to identify the cause of the error. Please provide them with screen captures of what you're seeing along with outlining the troubleshooting steps you've already tried.



  • Adrian Mandile CHESS
    Adrian Mandile CHESS ✭✭✭✭✭
    edited 07/26/21

    Thanks Genevieve,

    I have tried using different browsers (Chrome) without any existing login profiles and still can't get past the "Error making "getItems" request to extensible plugin. Error : Bad Request" message, when I try to select a D365 item (Smartsheet side is ok). The initial registration process works fine.

    My orgSystemInfo file shows that I have admin access on both sides of the connection.

    I have been able to get a Smartsheet to D365 connection working in Microsoft Power Automate, but get the exact same error with Zapier and Smartsheet Connector App – and I can't understand why.

    However, the triggers/actions available in Power Automate are not detailed enough for me to check for updated rows and return selected column values to D365 records or vice-versa from D365 updated record to a specific row in Smartsheet.

    Has anyone got this Connector App to work? or encountered/overcome a similar error? – The error message seems to be a "known problem" in the Zapier community.