Outlook Add-in not working for multiple users / non supported browser

08/26/21
Accepted

Hello! I have a few users that use the Outlook add-in that reports that when they try to sign into the add-in, it tells the that they are using an unsupported browser.

I can confirm that they are using the latest versions of their browsers (Chrome and FireFox) and since this has hit multiple users, I am thinking there is a bug in the sign in process? Does anyone else have this issue?

Best Answer

  • Answer ✓

    With Genevieve's answer, I have found out that the user's Outlook were not as updated as I thought. The version of Outlook as noted in the Browsers link was indeed using Internet Explorer 11. I installed the lastest Office version and was able to get the user to sign in without issue.

    Again, thank you @Genevieve P. for getting me to the correct solution!

Answers

  • Hi @CapMReynolds

    Based on your screen capture, I can see that the pop-up window is not being opened by Chrome or Firefox. Microsoft Office has its own default browser based on your computer's operating system and platform.

    I found an old thread on this topic in Stack Overflow (here) which confirms that if you're opening a link that connects back to Outlook, it will open in Outlook's default browser to communicate back, versus your device's default.

    Here is Microsoft's documentation on their browsers: Browsers used by Office Add-ins

    It sounds like the users who are experiencing this issue may be in the range that has a default browser of Internet Explorer 11, which is no longer a Smartsheet supported browser (see: System Requirements and Guidelines for Using Smartsheet).

    I also found a thread in the Salesforce Community where users were experiencing a similar issue. Salesforce then wrote an article detailing troubleshooting steps to try and fix this, see here: Links in the 'Salesforce for Outlook' and 'Outlook Integration' Panels do not open a browser or load in the wrong browser

    I would go through the steps in that article to see if it helps resolve the issue. If it has not, and your Outlook continues to open Add-On pop-ups in IE 11, then this issue is specific to Microsoft. In this instance, I would recommend providing feedback on Microsoft's article linked above and contacting their support team about this.

    I hope that helps!

    Genevieve

  • Hello and thank you for your information! I did see that there there was a change where Internet Explorer 11 was no longer supported after August 17th. https://help.smartsheet.com/articles/2480976-browser-support

    Maybe the user did not use it from then until now... having said that, since Outlook does use IE / Microsoft Edge (not legacy in latest Windows builds) I would have thought the Devs would provide a solution to those who uses the add-in. :) Looks like I have some more researching to do as I don't know how to change the browser window to Chrome for add-ins.

  • Answer ✓

    With Genevieve's answer, I have found out that the user's Outlook were not as updated as I thought. The version of Outlook as noted in the Browsers link was indeed using Internet Explorer 11. I installed the lastest Office version and was able to get the user to sign in without issue.

    Again, thank you @Genevieve P. for getting me to the correct solution!

  • I'm so glad you were able to resolve this, @CapMReynolds! Thanks for letting me know that installing the latest Office version worked for you.

  • What was the Office version number that cleared this up? I have clients on version 2102 with this problem.

    Thanks

Sign In or Register to comment.