Why is Dynamic View adding quotation marks to drop down selections?

Rick_Bailey
Rick_Bailey ✭✭✭✭✭
edited 06/14/22 in Add Ons and Integrations

Hi,

I noticed that quotation marks are appearing around particular dropdown selections w/in dynamic view, that are not present on the master sheet. other dropdowns in the same column do not have them. Why would this be the case, and how do I fix {since they are not present in the drop downs} ?


Thanks!

Best Answer

  • Genevieve P.
    Genevieve P. Employee Admin
    Answer ✓

    Hi @Rick_Bailey and @christina.paz

    I've tested using a multi-select field in Dynamic View and was able to determine why this is happening (thank you for the screen capture, Christina!)

    Quotation marks will appear in the View in Dynamic View if the single multi-select value has a comma in the text. The quotes in Dynamic View are there to show that the string is all one value, since the formatting in the View Display uses commas to separate the multi-select values.

    For example, see how in my second row I have two Values selected, which are then parsed out with a Comma in the view.

    However as soon as I have one multi-select value that contains a comma within the text, the View display shows it with quotes to group that text together.

    The Details tab should show your multi-select values as individual values in grey squares:

    If you don't want quotes to appear in the page view, I would suggest using a different separator in your value... perhaps a - or / instead?

    Let me know if updating your formatting has resolved the issue or not!

    Cheers,

    Genevieve

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Rick_Bailey

    Would you be able to post screen captures of the data in Dynamic View and the Column Properties of the column in the source sheet (but block out sensitive data)?

    I haven't seen this happen automatically before and I would like to try and replicate the behaviour; my current guess with the information provided is that the users are manually adding quotes.

    Cheers,

    Genevieve

  • Rick_Bailey
    Rick_Bailey ✭✭✭✭✭

    Thanks @Genevieve P. ; there must have been a glitch that self corrected, as the quotes are no longer visible. I had checked the source data at the time, and there were no quotations there either. Not sure what happened, but all appears ok right now. I'll circle back if it pops up again.


    Thanks!

  • Genevieve P.
    Genevieve P. Employee Admin

    Strange one...glad to hear it's fixed!

  • christina.paz
    edited 03/25/22

    Hi! I am seeing this happen on my sheet as well. Any advice on how to fix it? Thanks!

    @Genevieve P.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @christina.paz

    Since there's only one value that has quotation marks, is it possible that this one dropdown selection has quotations marks in the Column Properties in the source sheet?

  • Rick_Bailey
    Rick_Bailey ✭✭✭✭✭

    Hi @Genevieve P. , the quotation marks came back again on mine and are present on some, but not all values. To confirm, I have no quotation marks in the actual drop down selections. Thanks!

  • @Genevieve P. Same as Rick, I do not have any quotations on that checkbox value. I'm having to manually edit each entry (across different automated folders) in order to send these without those quotation marks showing by changing the name of the value.

  • Genevieve P.
    Genevieve P. Employee Admin
    Answer ✓

    Hi @Rick_Bailey and @christina.paz

    I've tested using a multi-select field in Dynamic View and was able to determine why this is happening (thank you for the screen capture, Christina!)

    Quotation marks will appear in the View in Dynamic View if the single multi-select value has a comma in the text. The quotes in Dynamic View are there to show that the string is all one value, since the formatting in the View Display uses commas to separate the multi-select values.

    For example, see how in my second row I have two Values selected, which are then parsed out with a Comma in the view.

    However as soon as I have one multi-select value that contains a comma within the text, the View display shows it with quotes to group that text together.

    The Details tab should show your multi-select values as individual values in grey squares:

    If you don't want quotes to appear in the page view, I would suggest using a different separator in your value... perhaps a - or / instead?

    Let me know if updating your formatting has resolved the issue or not!

    Cheers,

    Genevieve

  • Rick_Bailey
    Rick_Bailey ✭✭✭✭✭

    Thank you @Genevieve P. !