Data Shuttle deleting my whole sheet??

Susan Vieira
Susan Vieira ✭✭✭✭✭
edited 06/14/22 in Add Ons and Integrations

I have a mystery with my Data Shuttle workflow and I cannot figure it out. I have been using it successfully for the past several months and today for some reason, when I upload a new attachment, it deletes all my rows in my target sheet. The unique identifiers are still the same and I cannot figure out what is different this time that it would delete everything.

Any insight?

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Susan Vieira

    It sounds like perhaps your DataShuttle workflow is configured to "Delete rows that no longer match the filter criteria", could that be the case? If so, it may be that the unique identifiers are no longer finding a match between your two documents.

    I would recommend importing your source sheet in manually and then you could use a COUNTIF formula to see if the unique values are matching between sheets.

    You may also want to reach out to Smartsheet Support with a screen recording of your entire workflow set up, the source file, and an image of the sheet in Smartsheet (and url). They'll be able to troubleshoot this with you in a private channel where you can share more details.

    Cheers,

    Genevieve

  • Susan Vieira
    Susan Vieira ✭✭✭✭✭

    Thank You @Genevieve P.

    I have no filter criteria set up and we changed nothing in the DataShuttle workflow which worked properly last week which is why we are stumped.

    I manually checked all unique identifiers and everything is identical to the last time we ran it so it is quite the mystery.

    I will definitely follow up with Support since this seems to be more complicated then me simply overlooking something. Thank you so much for your input.


    Susan

  • Paul H
    Paul H ✭✭✭✭✭

    @Susan Vieira Last time this happened to me the person sending me the excel report had made a barely noticeable change to some column headers.

  • Susan Vieira
    Susan Vieira ✭✭✭✭✭

    @Paul H , thanks!! I will have them double check!