Cannot sort rows.

Hey there,

found similar questions, but none with an actual answer, so hoping someone could help.

People cannot sort rows in a sheet, as the options is greyed out. Users in question have "Editor - can share" access, no filters are applied, and the column I'm trying to sort is not locked. Any thoughts on what's happening?


Thank you.

Answers

  • Summer
    Summer ✭✭✭
    edited 04/27/22

    Hi @MarianaMA

    I had the same thing happen to my users. The culprit was an active filter. If the sheet has a filter on it the sort option will be greyed out.

    ooo, just re-read your comment that said no filters are applied and the rows aren't locked. That really is a head scratcher. Smartsheet has been glitching out lately in the most random ways. Perhaps this is one?

    Kindly,

    Summer

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @MarianaMA

    Even though the column is not locked, is it possible you have certain rows that are locked?

    See: Sort Rows to Organize Your Data

    • Although Editors can sort a sheet, they can't sort locked rows. If the Sort Rows option appears unavailable, and you're shared to the sheet with Editor permissions, deselect any locked rows before attempting to sort.

    Can you also confirm that this is a Sheet type of Smartsheet item and not a Report? If it's a sheet, without locked columns or rows, or a filter applied, it would be helpful to see a screen capture of what they're seeing (but please block out sensitive data).

    Thanks,

    Genevieve

  • rfj0001
    rfj0001 ✭✭

    I had a similar issue where a sheet was shared to multiple users. It was a Sheet type of Smartsheet item. We detected no row-locking in place. One of them had Editor-can share permissions and could not sort (the option was grayed-out), the other had Admin permissions and could sort rows. Changing the permissions from Editor - can share to Admin solved the problem.