Barcodes not working anymore


I have an inventory sheet that I have put together for our small business inventory. I have many items already entered with barcodes I generated myself online. Everything was working great until yesterday. I had some new items I needed to enter. I went through the same process I have been using. I go to test the search feature and scan my new barcodes. I was given the message that the Item I had scanned was not found in the sheet. I tried creating new barcodes, restarting the app, and logging out and back in. Nothing worked. Does anyone have any experience with this. I have already put in a lot of time and effort. I am using the same exact barcode generator that I used from the beginning, and now I am stuck.


  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Felicia1211

    I hope you're well and safe!

    Can you maybe share some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too,

    I hope that helps!

    Be safe and have a fantastic weekend!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up, Awesome, or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: | | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Felicia1211

    When I scan the barcode on the left (same barcode that is in the yellow line) I get the above response. This is the response I get for all barcodes created yesterday through today. I have tried making new barcodes and replacing them and that didn't work either. It's like the app is not searching properly. I uninstalled and reinstalled it and that didn't work either

  • Genevieve P.

    Hi @Felicia1211

    It looks like the barcode number in the image is different than the number in the cell; the barcode scanner will bring in the numbers to search (as in your first image), but the SKU with the numbers in the cell end in 833, not 8331.

    Is it possible this cell was edited accidentally? You can right-click and check the cell history if that helps.

    Join us at Smartsheet ENGAGE 2024 🎉
    October 8 - 10, Seattle, WA | Register now

  • Dale A

    I currently am having this happen to me. Every entry that I have made today and added barcodes to gives me the "No results found..." error. Everything was fine until today, I added over 50 items into my Smartsheet yesterday and can scan them all fine, it's just anything new today, all 10 Items I added today give me the same error. I have checked multiple times to be sure that I am not missing any numbers in the codes. I see no reason why it's not working today.

    I see in the pictures above that numbers were not matching up, mine however do. When I scan the barcode on my phone it's not linking to the Smartsheet for some reason for any of these new items.

    Is this happening to anyone else?

  • TaceyB

    The barcode scan feature is still not working. The mobile app will not scan anything. When will a fix for this be released or deployed?

  • KPH
    KPH ✭✭✭✭✭✭

    Hi @TaceyB

    Scanning is working fine for us. Maybe there is an issue with your device, or app. At the risk of being a cliché, can you try closing the app completely and opening it? If that doesn't work, maybe raise a support request. Good luck!