Move Row: Will not move if condition has a dropdown list

Options
jc carley
jc carley
edited 12/15/22 in Smartsheet Basics

Hello,

I am trying to automate copying a row from master sheet to child sheet.

The trigger is when a row is changed to "New" it should copy to the child sheet. This is one of 4 choices in the column. It is a column with dropdowns.

When creating the automation, I am not able to choose "new" as the thing it changes to in order to kick off the automation. Columns that are just text function correctly, but if it is a dropdown list, it is not working.

Any thoughts?

Answers

  • Debbie Sawyer
    Debbie Sawyer ✭✭✭✭✭✭
    edited 12/15/22
    Options

    Would it be possible to show a screen shot to explain where/how you are selecting the option.

    I have many automations running from dropdown lists, so I believe you should be able to do it.

    Very simple screenshot here...

    Status is a dropdown list with 3 values in the sheet.

    This is the trigger area of a workflow (In this screen shot Status is a Single Select dropdown)

    I would be able to click New here then when the row is changed to New the action would perform.

    HOWEVER!

    If the Status was a Multi-Select dropdown then the trigger changes and doesn't allow the value to be selected - so you'd have to put the value in a condition box instead - see below: (In this screen shot Status is a Multi-Select dropdown)


    Does this help at all?

    Kind regards

    Debbie

  • jc carley
    Options

    Yes! That helps explain it. My dropdown does have multi select.

    I did the condition "has any of" and checked the one I needed. I left the "otherwise" alone. Then had the action as "move to" and selected the new sheet.

    I am able to make it work if I click on the automation and say "run workflow now on whole sheet" however, I need it to work as I add new items. I can't do the above every time as it duplicates things or I have to remember which rows to run. Not sure why it will not run when triggered.

    I save sheet, refresh master sheet and refresh target sheet. No dice, even when I look at bottom of sheet.

    Any thoughts?

    Thanks!

  • jc carley
    Options

    So oddly enough, it worked correctly once (test3). When I tried to replicate it (test 4 and test5), it did not copy to new sheet.

    Any thoughts?

    Here are screen shots:


  • Debbie Sawyer
    Debbie Sawyer ✭✭✭✭✭✭
    Options

    Thanks for the screen shot.

    Are you certain that Purpose is changing to the value after the rule was set and saved.

    To test again I would delete the value in purpose, in rows Test 4 and Test 5

    Save the sheet.

    Then put the purpose back into rows Test 4 and Test 5 as "Study Procedure"

    then

    Save the sheet.

    Wait.

    The workflows can take a few minutes to fire. Ensure you are not working in tabs on your browser as this could give some refresh issues.

    Open the destination sheet a couple of minutes later and see if the rows have appeared.

    If not, I am happy to zoom with you and watch the testing and I might spot something else whilst observing.

    Good luck!

  • jc carley
    Options

    Thank you. I will give that a try again. I have saved then refreshed master sheet, then added in test 4. Then saved and refreshed again. Then I open a new tab with target sheet and refresh that sheet. To no avail. But when I did the above with test 3, it worked.

    A zoom may be helpful.

  • jc carley
    Options

    But we would need to work on test sheets as the real ones have private info within them. I can create test sheets.

  • Debbie Sawyer
    Debbie Sawyer ✭✭✭✭✭✭
    edited 12/15/22
    Options

    email me on debbie.sawyer@smarterbusinessprocesses.com and I'll send you a zoom invite.


    Working on test sheets is not a problem for me.