User access issues

Dear all,

I'm having a strange user problem and I'm not sure if anyone else has run into it or knows what's up.

I'm trying to collaborate with a "free user" colleague on a shared sheet - she needs to be able to generate pdf documents per row. In the access testing phase I tried the process with two other users as follows:

1) The first user registered as a free user for Smartsheet on her own, and chose the "join your team" option during that process, which then sent a request for a license.

2) The second user registered with assistance, and chose the "not now" option at the "join your team" step, thus didn't request a license and could just go ahead and log in.

Both users were then set as editors for the sheet.

User 2 can access the "generate document" option on the sheet.

User 1 can't, although their access rights are set exactly the same.

I then tried this with a third user, who had previously registered (and as it happens requested a license), and she is also not able to access the option to generate a document.

This same issue has reflected in other aspects, such as "license requesting" users (for lack of a better term) not being able to access shared dashboards, or certain functionalities.

Does anyone know why this is, how I can fix it, or whether I can somehow force a "de-register" so that I can re-register users without generating a license request and the above problem? Would it help to create a contact list and add all colleagues as free users?

Your input would be much appreciated.