Alert Someone Workflow Not Working

I created a sheet with an automation that alerts someone (names I hardwired into the automation) at a specific date and time. No condition rules. For some reason, it does not work at all. Even when I try to have the notification sent to myself, it does not work. I have duplicated the workflow and even tried to copy the sheet to get it to work. Even after creating a new workflow from scratch I cannot get it to and I don't know why. Has anyone else had this issue? I attached a screenshot of the test notification that still doesn't work.

To add: everyone I tried to send it to has viewer permission of the sheet and access to their Smartsheet account.

Answers

  • Colleen Patterson
    Colleen Patterson ✭✭✭✭✭✭

    @karafulton

    In the automation, when you "Run Now" does it work?

    I created the same automation workflow off the "Remind Someone on a specific date" template:

    When I am testing this as Run now, it does send the anticipated message.

    If my answer helped you, please be sure to mark it as Accepted to help future learners locate the information.

  • It does not. It says it runs successfully but doesn't send to my email, nor does it populate the "Last Run" date on the automation.

  • @karafulton

    Do you have multiple workflows on the sheet or even workflows in several sheets influencing eachother direct or indirect.

    I had this a few times. In my case it had to do with Smartsheet detected a deadlock:

    • workflow A was triggered by a change X and does an action which alters Y
    • workflow B was triggered by a change Y and does an action which alters X

    In this case this would result in a deadlock, which was luckily noted by the System, but no message or warnings.

  • Colleen Patterson
    Colleen Patterson ✭✭✭✭✭✭

    @karafulton can you trying using the template that I mentioned? Also, have you checked your automation preferences?


    If my answer helped you, please be sure to mark it as Accepted to help future learners locate the information.

  • @karafulton did you get a resolve to your issue of not receiving "Alerts"? I am having the same issue. I tried "Send to specific people" and "send to contacts in a cell" - the later was the auto created by and I also tried it w/ a contact list column. No alerts were sent in any of the conditions. I have put myself as the first two "Request and Update" so I know the permission settings are accurate as I had receive both of them. If you happened to find a solution, please let me know. Thanks.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @CWibben

    Can you post screen captures of your workflow set-up, identifying how it's triggered (e.g. manual change in the sheet or by a date), and circling the blocks that aren't working as expected?

    Thanks!

    Genevieve

  • CWibben
    CWibben
    edited 05/31/23

    Thank you @Genevieve P. for your reply. The workflow works good through the Request an approval (Manager) & the Request an update (PR Request approved - CREATE a PO), but the "Alert someone" does not. I've tried adding specific people, chose from contact column, added a condition, and I've turned off all other workflows to be sure there was no conflict. Still no notification was sent. I've used my name in all scenarios, so I know it's not a permission issue as I am receiving all other request/notifications.

    Example of send to a specific people.

    Examples of contacts list in columns. I've tried all 3.

    Any suggestions?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @CWibben

    If it's only the Alert block that's not sending you the email from the same workflow, can you check your Personal notification preferences?

    It sounds like this box may not be checked:


    If this box is not checked and you are the cause of the trigger (e.g. the Trigger of the workflow is when a cell changes, and it's you that makes the cell change) then you won't receive an email.

    Let me know if that was the problem!

    Cheers,

    Genevieve

  • BINGO! That worked. Your input was greatly appreciated! Thank you.