Automation Alerts Not Sending When Change Cell Action Is Included in Workflow

Options

I have several workflows on a sheet that alert the people in a Contact Column when certain events happen in the sheet . . . Invoice Paid Date added, Row Added, etc. Everything seemed to be working until I added a Change Cell action after the Alert action. Once I added the Change Cell action, it would run but the email alerts stopped coming. The workflows are set to run when triggered and the Change Cell action is running right away but the emails are simply not arriving. They were but no more.

Answers

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭
    Options

    Is the Change Cell workflow changing a cell that is used as either a trigger or condition in any of the alerts that are not sending?

  • Doug Carr
    Doug Carr ✭✭✭
    Options

    It is not. It's nothing but a CheckBox column that I added to see if the workflow had run. All but one of the workflows is triggered by a change in another single column. The alert is not referencing the CheckBox column either when it returns the data in the Alert.

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Doug Carr

    Are you getting the alerts from the email within the App, just not in your emails? (The bell icon).

    I'm wondering if the emails are being caught in a spam filter now, as they're coming from an automation. Here's an article that goes through some possible troubleshooting steps to check: Issue: Email Not Received from Smartsheet

    Cheers,

    Genevieve

  • Doug Carr
    Doug Carr ✭✭✭
    Options

    Not likely . . . I get plenty of automation emails from Smartsheet and I was even getting them from this app before I added the Change Cell actions to the workflows. And another strange development is that I heard from the other person whose contact is in the contact column used to send the emails and she did get them, whereas I did not. I am wondering if the issue may, somehow, be in the contact column. She is listed first and my contact is second.

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Thanks for clarifying!

    Are you seeing the alert in the app?

    Another thing to check: is it possible you have this setting un-checked in your personal settings?