Export to Excel Issues

Options

We are having issues when exporting our Smartsheet pages to Excel. In most of the cases where the column is defined as a "Text/Number" column, if there is not text WITH number (only numbers), it comes out scrambled in Excel (Below is the original taken from Smartsheet)


And below is how it exports to Excel (see top right hand side):



Can anyone offer any explanation as to why this is happening?


I should mention that in some cases the claim# field will be filled with text and numbers, and sometimes it is only numbers. There is no way to for us to restrict this column to one or the other. Has anyone found a way around this other to always include text with the numbers?

Best Answer

  • Kelly Moore
    Kelly Moore ✭✭✭✭✭✭
    Answer ✓
    Options

    Hello @Lisa76

    This has nothing to do with smartsheet- Excel will convert NUMBERS with many digits (I can't remember if it's 11 digits or 15) into scientific notation, which is what you're observing. This conversion only applies to numbers, as a text string has no limits. You can leverage the textstring as a wokaround but you will need another column. You can hide the column in smartsheet but in excel, it will be the field you will want to use.

    In a helper column use this formula

    =[Claim #]@row + ""

    This will convert your NUMBER value into a Textstring. If your Claim # is already a textstring, it will be unaffected except having a space on the end of it.

    Will this work for you?

    Kelly

Answers

  • Kelly Moore
    Kelly Moore ✭✭✭✭✭✭
    Answer ✓
    Options

    Hello @Lisa76

    This has nothing to do with smartsheet- Excel will convert NUMBERS with many digits (I can't remember if it's 11 digits or 15) into scientific notation, which is what you're observing. This conversion only applies to numbers, as a text string has no limits. You can leverage the textstring as a wokaround but you will need another column. You can hide the column in smartsheet but in excel, it will be the field you will want to use.

    In a helper column use this formula

    =[Claim #]@row + ""

    This will convert your NUMBER value into a Textstring. If your Claim # is already a textstring, it will be unaffected except having a space on the end of it.

    Will this work for you?

    Kelly

  • Erica L.
    Erica L. ✭✭✭✭
    Options

    Following up as I have a similar question, I see that my exported Excel file is converting any "Checkbox" column types from Smartsheet to a "True/False" answer when exported into Excel. Instead of the Excel file showing a checkbox, the result is text reading "TRUE" in the cell that has the checkmark in Smartsheet. Any way around this to show it "checked" with a symbol instead when it's been exported to Excel?