Smartsheet Integration for Slack

Hello,

I've integrated Smartsheets to my slack and see the icon under my apps. However, when I create a workflow and select "alert in slack channel" it shows public org channels instead of the one that I created. I would like notifications to only go to a few folks on the team, so I created a public and a private channel to test, but these specific channels don't show in the workflow. Can you help?

Also, can you point me to the reference guide on the meaning of each condition. For example, I want to receive an alert 2 weeks before a date. Would the correct condition I choose, "is in the last (days) - 14" or "in the next days - 14"?

Thank you!

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @D_Pham

    If your channel is private, you'll need to add the bot to the channel before you can find it in the workflow:

    1. Go to the private Slack channel you want to use. 
    2. Type @Smartsheet to add the Smartsheet bot. 

    After doing this, you should see your private channel show up in the list! If it doesn't show immediately, exit the sheet then come back to it - the list may need a re-fresh to pull in the new channel.


    In regards to timing, if you're looking to send the alert on specific days, you'll want to set up the Trigger for the workflow to be Date Based, looking at a date column in your sheet:

    Then you can change when it runs by clicking the small "on" to instead be "2 weeks before" the date, or whatever your timing preference will be:

    Let me know if this helped or not!

    Cheers,

    Genevieve

  • D_Pham
    D_Pham ✭✭

    Thank you Genevieve! The triggered worked and came through slack. When I added "2 weeks before" on one column that is date based, it alerts me on other columns as well that are not coming up in 2 weeks. Do you know why this may be occurring?


    I thought it would alert on one column instead of others.



  • D_Pham
    D_Pham ✭✭

    I reviewed my workflow and since I followed your steps, I see that you have it set to trigger an alert for the entire sheet. That works! I guess now I'm wondering if the trigger is for "2 weeks before", why is it alerting for dates in March, May & blank? thanks!

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @D_Pham

    Blank dates are seen as "in the past". If you're getting rows in your alert that you don't want, try adding a Condition Block to your workflow to filter them out... such as a filter that says that the date cannot be blank. 🙂

    Let me know if this works for you!

  • D_Pham
    D_Pham ✭✭
    edited 01/26/24



    Okay, so I have these conditions in the workflow as mentioned, however, I'm still receiving updates for dates that are far out. Am I using the incorrect conditions?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @D_Pham

    Can I clarify how you're testing this? If you're using the "Run Now" manual override function, this actually skips the "trigger" because you become the trigger. This means it will run the workflow for the whole sheet, ignoring what the dates are, but use your condition block to filter rows. Here's more information: Manually run a workflow

    Your set-up is correct so when a date in the Due Date column turns out to be 2 weeks from today's date, that one row will alert you 🙂

    Try setting a test row to be 2 weeks out from tomorrow's date and then see if tomorrow it triggers successfully!

    Cheers,

    Genevieve