Issue with dates input in smartsheet dashboard

Hello i'm having an issue with dates input into smartsheet. the format should be in dd/mm/yy but it seems the backend is reading it in mm/dd/yy. so when i select a date like below it completely changes and also it prevents me from selecting days that are greater than 12. see pictures below for example. i select in the dropdown calendar the 8th of February 2024 and instead it registers as the 2nd of August 2024.


Answers

  • heyjay
    heyjay ✭✭✭✭✭

    In the Config setting #5 - Time and Design check the Date format -

    If its not showing, click ADVANCED in selection #3 - Map Columns


    ...

  • Hello i think the issue was misunderstood. We have a dynamic view that is designed so that users can input tickets into a backend smartsheet sheet. The issue is when the user tries to add a ticket with a date, the dynamic view switches the date and month. This means for example if the user inputs a date like 10th of February 2024 (10/02/2024) in the calendar it shows as the 2nd of October 2024 (02/10/2024). If a date past the 12th of the month is input then the field appears blank in the dynamic view. Even stranger, when inspecting the backend sheet the dates are read correctly as expected.

    Here we select the 10th of February

    The dynamic view however reads it as the 2nd of October.

    However in the backend smartsheet the date is read correctly as the 10th of February 2024.

    P.S we tried to follow the solutions above but we couldn't find any of the settings, perhaps it doesn't apply to the dynamic view.

    Thanks and Looking forward to your response

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Adiele Ejiofor

    I checked in with our Support team and they confirmed you've been in contact with them about this behaviour; our Engineering team is looking into this but we don't have an ETA for a fix just yet.

    In the meantime, you could temporarily set your Personal Settings > Regional Preferences to English (United States).

    Cheers,

    Genevieve