Smartsheet not recognizing date (and date filters in report not working)

Options
KLZolali
KLZolali ✭✭✭
edited 03/06/24 in Add Ons and Integrations

I'm having an issue with my reports not recognizing that a date is in fact a date. The original date is coming into a sheet via DataShuttle and is formatted "2012-05-15T04:00:00+00:00". I have written a formula to extract only the "2012-05-15" in a different column, and both of those columns are date-type columns. I have also tried a third format date extract of "05/15/2012" to no avail.

If I change the column to text/number, save, then change it back to a date-type column, the sheet updates the format momentarily and the reports work, but then it reverts back minutes later. So frustrating! Anyone have any ideas for workarounds or something I'm doing wrong?

Answers

  • Ric T
    Ric T ✭✭✭✭✭✭
    Options

    Hi @KLZolali,

    Have you tried manually toggling the entire date-type column to your desired format on the main toolbar (highlighted below)? This would ensure all your rows are consistently formatted. After that, try creating a new report entirely, relink your source sheet, and apply the date filter.

    If that doesn't work, could you share a screenshot (redact any sensitive info) of the filters applied to your report?

    Cheers,

    Ric

  • KLZolali
    KLZolali ✭✭✭
    Options

    Hi @Ric T

    Thank you for the response. I tried your suggestion of changing the date-type column on the toolbar, and it didn't resolve the issue (likely because those date columns were results of formulas?).

    After the DataShuttle runs each month, I'll have to go back into the sheet and change the column type to Text/Number, and then back to Date. Smartsheet then removes the timestamp on it's own without having to use formulas. It's not perfect, but it works. Thanks again for your help!