Salesforce connector - rows not meeting filter are not being filtered out

Options

In Smartsheet I have a sheet with an integration to Salesforce. I have configured the integration to only pull in rows that meet a certain criteria.

To test the integration, I ran the integration to pull in data. I them went to Salesforce to edit one record of the data that was integrated to no longer match the filter conditions.

The only way I can get this record filtered out of the Smartsheet is to manually run the workflow. If I just wait the connector will update other records if new data has been entered, but the row that no longer meets the filter remains in place?

Answers

  • jessica.smith
    jessica.smith ✭✭✭✭✭
    Options

    @ESzczesuil

    I don't believe that the Salesforce Connector can remove items from the connected sheet, only add and sync. On my connected sheet, when a record no longer meets filter conditions, it's nested under a row called "Filtered out by Connector - not synced" (screenshot below).

    If I wanted to remove the rows that no longer meet the filter criteria automatically, I would probably set up this workaround.

    1. Set up a column with a column formula that allows you to distinguish between rows that are still being synced to Salesforce and those that are not. I'd use this formula =COUNT(ANCESTORS()) which will count the number of ancestors each row has. Only the records that don't meet filter criteria should equal 1 once they are nested under the "Filtered Out" row.
    2. I'd set up an automation on the sheet to MOVE the rows that no longer meet the filter criteria to a helper sheet. The trigger would be, when rows are changed and "Ancestors" changes to 1.

    Do you think something like this might work for your use case?

  • ESzczesuil
    Options

    @jessica.smith Thank you for your reply. What you have described is probably a more detailed explanation of what I meant by 'filtered out'. I understand Smartsheet will not remove the data, and instead will move the row under the parent row "Filtered out by Connector - not synced", but my issue is - I can only get this to occur when I manually force the intregration to run. Otherwise the row that should be moved as a child to the above noted parent row remains in place.

    If I am in Salesforce and update a record (keeping the record within the integration filter) I see the updates reflect in Smartsheet immediately. But when I edit a record in Smartsheet to no longer meet my filter criteria for the integration, this is when nothing occurs.