Welcome to the Smartsheet Forum Archives

The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Column headers not available to select from Excel import

Eric W.
Eric W. ✭✭✭✭
edited 12/09/19 in Archived 2016 Posts

I have imported many Excel files to Smartsheet.  however, I cannot figure out why I cannot select the column headers from my Excel file as the column headers in Smartsheet.  

I've tried changing thigns in Excel in attempt to support the import:

  • cell type from "general" to "text
  • removing filter option
  • removing and adding text wrapping
  • removing freeze panes
  • I tried saving the file as .xlsx vs. .xls (tried both formats)




  • Travis
    Travis Employee

    It looks they are a different cell type. Try adding a new row to your Excel file and copy and paste just the text from the first row to the new row - then import. Does that work?

  • Eric W.
    Eric W. ✭✭✭✭

    Hi Travis,


    That did not work.


    I did copy just the data into a whole new Excel file and that seemed to work.


    Thanks for the input.



  • Krissy Scheffer
    edited 05/31/16

    I'm also experiencing this issue. Has there been a resolution? 

  • Kennedy Stomps

    Hi Krissy, can you try right-clicking the desired tab to import in your Excel workbook and select Move or Copy... and use the dropdown under "To book:" to select New Book and check the box for "Create a Copy"? This will create a copy of your sheet in a new Excel workbook. Then, try importing this newly created file. I have seen this resolve importing issues in the past.


    If not, please send me a copy of the Excel file you're attempting to import at Kennedy.Stomps@Smartsheet.com and I'll be happy to assist further.

  • Thank you! I emailed the file. 

  • jkendley34311

    I have tried the steps above and my 439-row spreadsheet still previews the import starting at row 359, not showing header rows.

    Can I send it to you to take a look?

  • Adam Brizuela

    Has there been a fix for this or has anyone figured out a work around? 

  • hanseric
    hanseric ✭✭✭✭

    I was having this issue too and it turned out to be a second sheet was feeding values to the main sheet somehow (it was someone else's sheet that they asked me to use as the import to create a new smartsheet).

    Once I deleted the second sheet and manually gave the column a new header, the SS import recognized the column headers.

This discussion has been closed.