Issue with permissioning SS for MS teams notifications


I've been trying for 2 months to address an issue with setting up automated notifications from SS to MS teams wherein I get the following error. My IT support team have tried granting me admin rights in the permissions menu of the Azure AD but it's really not clear how to resolve this issue. We have also tried getting an admin to sign in but the system doesn't allow them to do that (it just reverts back to my login details through the microsoft single sign in) Any experience/guidance people have with resolving this specific issue would be much appreciated before I give up on it altogether!


  • SoS | Dan Palenchar
    SoS | Dan Palenchar ✭✭✭✭✭✭


    I set up on MS Teams automations and it was a pain... This was a while ago so I am working from memory a bit.

    I remember having to first set up the Smartsheet integration within teams, be added to the teams account, and then create the automation in Smartsheet and link the accounts that way.

    It looks like you need to get the Smartsheet integration installed into teams, which should be doable by looking at the apps section in teams.

    👨🏼💻 Dan Palenchar | School of Sheets Solutions Consulting | Smartsheet Aligned Gold Partner

    If this helped, help me & the SSC by accepting and reacting w/ 💡insightful, ⬆️ Vote Up, and/or ❤️Awesome!

    PS - If you have a follow up response tag me @SoS | Dan Palenchar so I get notified of your reply!