Column type keeps changing itself to "Date" type

The data type of one of my columns is repeatedly converted to a “Date” data type from a "Dropdown (Single Select)" column type. When I return the data type to a single-select checklist, it is repeatedly converted back to a date data type. Is there a way to prevent this from occurring?

I have tried moving the column away from other date/time columns, but it does not resolve the issue. I am also trying to identify precisely the cases in which this occurs, but it appears to be both when a column is manipulated and when there are multiple users editing one sheet. (The functionality of this sheet requires new rows to be added by various users.)



  • Hello @Cara Fagerholm ,

    Although this behaviour is strange, I have a feeling that this could be a Merge Save occuring. This usually occurs when multiple users are making modifications in a Sheet at one time, and when attempting to save, it reverts the actions taken.

    To confirm this, please access your Sheets Activity Log and verify if the Column was actually changed. If nothing shows within the Activity Log, then a Merge Save has most likely occurred. See more on the Activity Log here:

    For further troubleshooting, you may wish you reach out to our Support Team here:

    Kindest Regards


  • It seems that this is due to dependency settings: date range display. My guess is that the column changing to Date was initial a date and set as start or end range. And later on it keeps turning to it's original type.

    The solution is here:

    From above link by @Alejandra :

    Thank you for submitting a support ticket regarding this behavior. Our support team has confirmed this behavior is a bug and has provided the following steps as a work-around:

    1. Set the column type of the column that is changing to a Date column by double-clicking the column name to bring up the Edit Column Properties window. Under Column Type, select Date. This is necessary so that all settings are cleared correctly when it's changed back to the type you want.
    2. Insert two (temporary) columns and set the Column Properties to Date using the same method as step 1.
    3. Right click on any column and select Edit Project Settings. Make note of the columns names listed in the Start and End date column drop-downs as you'll need the names for step 8. (The column that keeps changing should be one of them.)
    4. In the Start date and End date columns drop-downs, select the new temporary Date columns.
    5. Change % Complete to "--None--" if it isn't already.
    6. Click OK.
    7. If you have Conditional Formatting on either of the columns that were listed as the Start or End date, first, make a note of the rules (so they can be recreated after this process) and then delete the rules.
    8. Edit the Column Properties of the columns you made note of in step 3 (these were originally listed in the Project Settings dropdowns for Start date column and End date column) and change them to the property type that the column was in step 1 before it was changed to Date.
    9. Delete the 2 temporary date columns by right-clicking the columns and selecting Delete Column.
    10. Re-apply any conditional formatting rules, if applicable.