Bug: Text/Number Field changes itself to Date field for column.

edited 12/09/19 in Smartsheet Basics

This has been happening several times a day where a column I have designated for text input changes itself to a date field.  I have data being input by form users to rows.  They go to use the form and are presented with a date field where they are supposed to be inputing several sentences of text for their daily report.  I go in and manually change the field type back to Text/Number so they can use the form (several times per day)

I've contacted SmartSheet tech support.




  • Alejandra
    Alejandra Employee


    Thank you for submitting a support ticket regarding this behavior. Our support team has confirmed this behavior is a bug and has provided the following steps as a work-around:

    1. Set the column type of the column that is changing to a Date column by double-clicking the column name to bring up the Edit Column Properties window. Under Column Type, select Date. This is necessary so that all settings are cleared correctly when it's changed back to the type you want.
    2. Insert two (temporary) columns and set the Column Properties to Date using the same method as step 1.
    3. Right click on any column and select Edit Project Settings. Make note of the columns names listed in the Start and End date column drop-downs as you'll need the names for step 8. (The column that keeps changing should be one of them.)
    4. In the Start date and End date columns drop-downs, select the new temporary Date columns.
    5. Change % Complete to "--None--" if it isn't already.
    6. Click OK.
    7. If you have Conditional Formatting on either of the columns that were listed as the Start or End date, first, make a note of the rules (so they can be recreated after this process) and then delete the rules.
    8. Edit the Column Properties of the columns you made note of in step 3 (these were originally listed in the Project Settings dropdowns for Start date column and End date column) and change them to the property type that the column was in step 1 before it was changed to Date.
    9. Delete the 2 temporary date columns by right-clicking the columns and selecting Delete Column.
    10. Re-apply any conditional formatting rules, if applicable.