Error on running Smartsheet backup tool

Options

Hi,

I am trying to use the Java command-line backup tool to backup the Smartsheet data of our accounts, but there is always an error:

***ERROR*** IllegalArgumentException - Property 'accessToken' is missing

I have already specified the values of accessToken and output directory in the property file "smartsheet-backup.properties". I have no idea why it still doesn't work. Can someone advise? Thanks!


Ivan


Below is the content of the property file:

accessToken=xxxxxxxxxxxxxxxxxxxxxxxxx

outputDir="C:\temp\backup_test"

# The following properties are optional. To use them remove the pound at the start of the line of the property

#continueOnError=true

#zipOutputDir=true

#downloadThreads=4

#allDownloadsDoneTimeout=2

Answers

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Ivan Tam

    The first thing I would try with this error is to have the System Admin for your organization regenerate a new API Access Token in case there was an issue with the current one you're using (see Authentication and Access Tokens). Please note that for this tool the API token needs to be associated with a System Admin account.

    The next thing I would check is the Java Runtime Edition that you're using. The backup tool requires a minimum of Java Runtime Edition 7, however I have seen reports that the Java 8 environment is more reliable (see: Java Platform, Standard Edition 8 Names and Versions).

    If this hasn't helped, the final thing I would do is re-download the backup zipped archive from the Backup tool documentation under Usage, here: https://github.com/smartsheet-platform/backup-java.

    Then if none of the three initial troubleshooting steps above have resolved your issue, please contact our Support Team with full screen captures and details, including these three tests that you tried, so that they can work with you in a private channel.

    Cheers!

    Genevieve

  • Ivan Tam
    Options

    Hi Genevieve,

    I tried the suggestions that you provided but the problem still exists. Actually I also reported my case to Smartsheet support team on March 15 (Monday) and a staff called Pamela replied me and opened a case number (04568331) for me on the next day. Then I sent the related screen captures and the property file to her. But I have never heard from her again even I sent email to her again for following up from time to time. I wonder if my problem is still being investigated.

    Thanks.

    Ivan

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Ivan Tam

    If you've followed all those steps and nothing has been resolved, then working with our Support team in a private channel is the best way to proceed. If possible, it would be most helpful for them to have a screen recording going through each of the steps you've tried.

    I checked in and I can confirm that your ticket number is still under review and being investigated. Thank you for your patience!

    If your plan has Phone Support included, you can call our Support team to check in on a ticket as well. The phone number will be in your account under "Plan Info", and the phone lines are open after 6am PST, Monday to Friday.

    Cheers,

    Genevieve