Why is an automated alert no longer working?

04/16/21
Answered - Pending Review

Our company has been using Smartsheet for over a year to organize the production process in our shop. Clients submit orders through a form, and when the order is added to the Sheet, we have an automated alert that is triggered to send a copy of the approval to 2 different email addresses.

Suddenly one week ago, the automated alerts stopped coming to only one of the 2 email addresses. 4 days later, the alerts began coming to both emails. Yesterday, they stopped coming to one of the email addresses again (the same email address as before). Nothing was changed in any setting for either platform between any of these days.

We use these emails to keep track of the original order that a customer places (sometimes the job card can be changed as it moves through production, and it helps to have record of exactly how the client sent it in). It does come to one of the 2 email addresses, but now that person is having to forward all the alert notifications to the other email address, and that isn't something that will work for the long run.

I have looked through every setting that I can think of in Smartsheet and Gmail. I have Googled and searched through the Smartsheet community. I cannot find any answers as to why this could be happening.

Thanks in advance for any suggestions or ideas!

Popular Tags:
Previous1

Answers

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    I would suggest reaching out to support.


    A few things to think about when reaching out to support...

    Is it just this one automation on this one sheet doing that? Are there other automations on the sheet? Is it happening on other sheets?

  • Hi Paul - thanks for your comment!

    I did reach out to support the day this first started happened through email, but they have not responded. We do not have a plan that offers phone support, so I have no other way to get in touch with anyone for assistance that I know of. That's why I came to the community boards hoping that someone would have an idea of what to try.

    I appreciate you responding!

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    Ugh. Well unfortunately it sounds like a bit of a bug on the back-end.


    If you would to answer the above, we may (or may not) be able to help with some additional troubleshooting.

  • This is the only sheet that we use for production, so I don't know of any issues with any other sheets.

    We also have automations set up to alert clients when their jobs are ready for pick up or shipping which are still active and working, as well as automations that help us with our quality control process that are also still functional. It is just this one specific automation with just one email that seems to be causing the problem.

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    Have you tried deleting the automation and then rebuilding it?


    Is that email on any other notifications?

  • I did try making a separate new automation with just that email to see if it would work, but it did not. I didn't want to delete the old automation completely because we HAVE to get these emails, and now I'm afraid that something is going to happen and we won't be able to get them at all to either one of the emails they are sent to.

    This specific email that is causing the trouble is not on any of the other notifications that we use.

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    So it is definitely something with that particular email address.

    This may seem like a silly question, but are they shared to the sheet?

    Have you tried setting up a test automation on a different sheet with that email as the recipient?

    Have you gotten any kind of response from Support yet?

  • Thank you again for your responses here!

    Not a silly question, but yes, it is shared to the sheet, and also this specific email address and automation has worked for over a year. It just suddenly stopped working one day for no reason.

    I haven't tried a test with a different sheet and that email address, but that is something I can try.

    No, I have not received any help from Support at all. I waited an entire week and then followed up with a response to my request, and still haven't heard anything. :(

    The good news is that randomly this morning, the notifications did start coming to the email address again. However, as I mentioned in my original post, this happened once before and then abruptly stopped again, so I'm not convinced that anything is fixed yet, but I'm hoping that maybe whatever was going on has worked itself out?? Is that possible?!

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    It is possible that it has worked itself out. I have seen stranger things happen in Smartsheet. Haha. I would still leave the ticket with Support open though just in case. I would also suggest reaching out to your IT department to see if they have any insight (maybe they got put in a spam folder or moved from "Focused" to "Other" or something along those lines).

  • I wish we had an IT department!! We are just a small, family run wholesale sign manufacturing company - and me asking the question here on the forum is all we've got for "troubleshooting". :)

    I'm really hoping that whatever was wrong has somehow fixed itself. I will definitely leave the Support ticket open in the hopes that they will contact me and possibly offer some insight into this not happening again.

    Thank you again for your time and help. I really appreciated it!

  • Hi @matt Pazzaglia

    I checked in with our Support team and they haven't received any communication from you (from the email address associated with this Community account). Can I confirm you used this form (see here) to reach out? Do you have the ticket number from the submission confirmation email?

    It would be helpful for Support to know the name (or direct URL) of the sheet in question, the workflow ID of the one that stopped working, the email address it is sending to, the date it last ran successfully, a date where it should have run but it didn't, and any relevant screen captures (such as of the workflow set up and the sheet in grid view).

    In the meantime, I would suggest reviewing the troubleshooting steps in this article, in case the automation may be blocked by your email provider: Issue: Email Not Received from Smartsheet

    One other thing to check would be to make sure you're not hitting the limit for number of workflows/automated emails sending in one day for your plan-type, see: Daily Notification Limits

    Cheers!

    Genevieve

  • Hi Genevieve,

    Thanks for your response. So, it was too good to be true. The issue had corrected itself for a couple days, but we are now experiencing the same problem again.

    The support ticket is Case #: 04616763. I did use the submission form you linked to fill out the request, but I had put in a different email address than the one I am am using here in the Community because I wanted to deal with Support. It looks like I was logged into my husband's (Matt) account when I sent the Community question but I had used my own email when I sent the Help submission (my name is Layne). We are both members of the same Smartsheet that is causing the problem.

    Should I provide all the information you said would be helpful in an email to Smartsheet or share it with you here?

    Also, it did work just yesterday, so I know that it isn't an issue with being blocked from the email end and it is not because we are reaching our daily limits.

    Thanks in advance.

  • Hi @matt Pazzaglia (Layne),

    Yes, I would suggest submitting a new ticket with Support providing all of the details I mentioned above. Make sure you're using the email address that owns the sheet & has the workflow to contact Support with so they know what account to look into.

    One other thing you could check in the meantime is to log into the Smartsheet account for that email (if there is one) and see if the notifications are coming through in the Notification Center within Smartsheet. This would indicate that there's an issue with the emails being blocked, versus an issue with the workflow triggering.

    Support will be able to troubleshoot with you privately, so you can share private information such as screen captures of the sheet and the email that the alert is no longer sending to.

    Thanks!

    Genevieve

  • Ok, I will submit a new help request using Matt's email address, and hopefully that will help someone to get in contact with me.

    I did log in to Smartsheet with the email account that is causing the problem, and the notifications are not coming through in the Notification Center within Smartsheet, so I don't think it is an issue with the emails being blocked.

    Thanks for your assistance!

  • Hi @Genevieve P! I submitted a help request to Support on April 22 (case #04642912), and I still have heard nothing back from them. The email notifications are suddenly not being received again after working for several days. This is having a very negative impact on the production process in our shop, and I don't know what to do when I cannot receive any help from Support. Is there any way that you can check on the status of my ticket?

    Thank you in advance!

Sign In or Register to comment.