Client name incorrect in Contact List background and will not change

04/21/21 Edited 04/21/21
Accepted

I inherited the Smartsheets/workbooks a couple of years ago, and I recently noticed (on an update workflow request I just created) that a client's name is incorrect. I can not change it. Any ideas where this name is stuck or how I correct it?


When I tried to figure out why this happened, I noticed that the name appears correct until I hover over it

When I click on the column properties, it shows correctly.

I deleted the name in the drop-down and deleted the person's name from every instance in that column on the sheet. Save, refresh. When I create a value to add their name back, the incorrect name shows back up as an option to add.

I have checked sharing settings for the sheets I have and can't find the incorrect name there.

I just went in to check the sharing settings on a workspace she has never been shared with, and both the correct and incorrect versions show in that contact list... So maybe the correct question is how to do you delete contacts from this screen?


Best Answer

  • Bassam KhalilBassam Khalil ✭✭✭✭✭
    edited 04/23/21 Accepted Answer

    Hi @Terri-Lynn Morrison 

    Yes for sure the Owner permission is the highest Sharing Permission Levels, I advise you to try the following:

    create a new sheet and share only this contact with which you are facing a problem and check if you will face the same problems.

    Best Regards

    Bassam.M Khalil


    ☑️ Are you satisfied with my answer to your question? Please help the Community by marking it as the accepted answer. It will make it easier for other Smartsheet Community members to find this solution or help to answer their questions.

Answers

  • Bassam KhalilBassam Khalil ✭✭✭✭✭

    Hi @Terri-Lynn Morrison

    Hope you are fine, please check the in your account the ( My Smartsheet contacts ) and check the user's names in ( User Management ).

    Best Regards

    Bassam.M Khalil


    ☑️ Are you satisfied with my answer to your question? Please help the Community by marking it as the accepted answer. It will make it easier for other Smartsheet Community members to find this solution or help to answer their questions.

  • Thank you for the quick reply. I had deleted the name from that location. I then noticed that my main sheet changed (profile picture disappeared). When I hovered over it, it showed correctly. After a few saves and about 10 min, I noticed that the profile image was back and it once again had the incorrect name. After the reply by @Bassam.M Khalil , I checked and the name does not show in the "my contacts" section at all.

    Do you think it is stuck in someone else's setting who no longer has access to the sheet? I am the current owner of the sheets/workbook. I am checking with my current team (all non-licenced users with no edit access to that column). I would have thought that my settings as Owner would trump any other ones or people who no longer have access to the sheet.

  • Bassam KhalilBassam Khalil ✭✭✭✭✭
    edited 04/23/21 Accepted Answer

    Hi @Terri-Lynn Morrison 

    Yes for sure the Owner permission is the highest Sharing Permission Levels, I advise you to try the following:

    create a new sheet and share only this contact with which you are facing a problem and check if you will face the same problems.

    Best Regards

    Bassam.M Khalil


    ☑️ Are you satisfied with my answer to your question? Please help the Community by marking it as the accepted answer. It will make it easier for other Smartsheet Community members to find this solution or help to answer their questions.

  • I created a new sheet as suggested and only added that name in a new contact list field. It still shows the incorrect name when I was creating the contact list. It did not matter if I started to enter first name, last name or email address; it had the wrong last name in the display when the mouse hovered over the name. I am thinking then that our I.T. department may have created it wrong at some point in the email system, and even though I.T. may have corrected it, Smartsheet is pulling an incorrect version. If it is a brand new sheet, with no existing list, that has not been shared with anyone, and I did not have that person listed in my personal contacts, it has to be automatically imported from Google as that is how I signed into Smartsheet. It does not show incorrectly in the Google Contact list.

    Oh, well. Thank you for the suggestions.

  • Hi @Terri-Lynn Morrison

    Is it possible that this user at one time had a Smartsheet account associated with their email? Perhaps when that contact was first created, a sheet was shared with them, creating a free collaborator account?

    If so, this would then be the name associated with their Personal Settings within their own Account. Email notifications show the name associated with the account (versus the name that you apply to a contact as your own name for them).

    To change this, you would either need to have them log in to Smartsheet and adjust their Personal Settings (see here), or if they are a member of your organization's plan, you can adjust their name from the Admin Center (see here).

    Cheers!

    Genevieve

Sign In or Register to comment.