Sheet sharing with filter


Hi I have created a smartsheet where I have multiple collaborators, and I want to let them see only information that I've sorted out by Department in one Filter.

So I want sales, to see only sales and marketing only marketing. When I try to do so under share and the icon by permission level - it gives a different symbol like a sheet instead of the option for the filter ( the filter is already setup). See my Sheet Sharing Picture 1. and I want to be able to see in my Sheet as the example on Picture 2.

Picture 1

Picture 2