Reports Showing Blank Results for Current User Filter

I'm sure this is user error but I've been trying to figure it out on my own and coming up blank. I have a couple of reports I've created and want to show returns based on the current user who is viewing the report.

I've asked different staff to test the view and they are both getting a blank screen. 😫 I'm not sure what I'm doing wrong or how to fix it.

For the first Report, I select the Current User in the filter:

But when the user tested it out (sent her the link/shared the report) she said it was blank.


The second Report, I have several different filter requirements, and want to have the current user see their assigned rows when they access the report. Different person than above tested and she gets blanks too. It is showing me one line, as I did a test line from the underlying sheet - assigning it to myself. So...not sure why it's showing me a current user view but not them.

What am I missing? I want to be able to embed the report into a dashboard but if the user can't see the data when they log in then I'm at a loss. I don't want to create multiple reports for each person. 😑

Tags:

Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Megan.Casto

    I hope you're well and safe!

    Are the users shared to the underlying sheet(s)? They have to be shared with them to be able to see their information in the Report.

    Did that work/help?

    I hope that helps!

    Be safe and have a fantastic week!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Yes the users have been shared to each of the underlying sheets. I'm at a complete loss.

  • I am experiencing the same issue and my users are shared to the report. It almost seems that their value of current user does not reflect their actual user name?