Is anyone having issues with Data Shuttle?

12/13/21
Answered - Pending Review

My workflows are not pulling in this month's data. These are not set on a schedule. I manually run them each month because my date fluctuates. No matter how many times I run, edit, or update, it will not pull in the current data.

Anyone else experiencing this issue?

Answers

  • Hi @Darla Brown

    I haven't experienced any issues with Data Shuttle this week personally, so it may be related to how the workflow is set up or the matching values.

    What does the "Last Run" column say? Does it indicate that the workflow ran, with a green check mark?

    If so, click on the checkmark to see the details of that last run. I would check to see if it filtered out all your rows under "unaffected" for some reason:

    If that's the case, I would check to ensure your unique identifier column has matching values across your two items.

    If you want to troubleshoot this in a private channel where you can share more details, please contact Support with full screen captures of the Last Run Log (like above), screen captures of how you set up this workflow, the sheet URL and screen captures of the grid of the sheet.

    Cheers!

    Genevieve

  • Darla BrownDarla Brown ✭✭✭✭✭

    My workflow hasn't changed all year and it has worked perfectly every month. My last run date was yesterday because that's when I manually ran it. The process runs but the data is not in my target sheet. I've not changed the workflow or parameters. Just added data in my original file. But it's the same process every month which is why I can't figure out the issue.

  • Hi @Darla Brown

    What does the run log say? Did it indicate that rows were Updated or Added, or does it say that it skipped all the rows (Unaffected)?

    If the Run Log says that rows were added is it possible they were added down at the bottom of the sheet, so you need to scroll down to see them?

  • Darla BrownDarla Brown ✭✭✭✭✭

    They were unaffected. I ran them again today and the same thing happened. All of my workflows are upload type. No matter if it's add, merge, or replace, they are not changing data.

    I've cleared my cache, used different browsers, reloaded the original document and made sure the workflow is correctly created. Still will not load November's data.

  • Hi @Darla Brown

    Thank you for clarifying that it says Unaffected, this helps!

    What are you using as the unique identifier to match between your source item and Smartsheet destination? It sounds like either the workflow is unable to find a match (so it's skipping all of the rows/data) or nothing has changed since the last run where there was an update.

    Working with Smartsheet Support in a private channel would be best so that you can share screen captures as I mentioned above; they'll need to see the matching values and would be able to test with your actual source item, if you're able to share it.

Sign In or Register to comment.