OneDrive File On Smartsheet

I am using a Smartsheet Dashboard for managing some files from OneDrive for and HOA. When the board tried to access the files though they say they are only available to internal users. I used the attach a OneDrive file. I am trying to avoid having to share each file to them and attach the link. Any suggestions. The board has edit permissions to the entire folder in OneDrive. Thanks for any help.

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @ShaymaGrossPPP

    I tested on my account and as long as my users were shared to the OneDrive folder then clicking a Shortcut Widget link directed users to the folder without issue. A couple of questions for you:

    • How are you storing the OneDrive links in the Dashboard, what widget are you using?
    • How are you sharing the Dashboard to these board members, are they shared to the Dashboard or are they looking at a Published version?
    • Finally, when are you seeing the error message, as they try to access the Dashboard or after they click on the OneDrive link?

    It would also be helpful to see a screen capture of the error message, if possible!

    Thanks,

    Genevieve

  • Here are the screenshots. We experience the error for users outside of the company. If they are inside the company it is fine. The external users are the issue. I have had to create individual links for each file which is a pain. The external users are shared to the entire OneDrive folder with Edit permissions. They are shared to the dashboard with Viewer permissions. Any help would be great.


  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @ShaymaGrossPPP

    Thank you for this additional information! That error message is actually coming from OneDrive, not from Smartsheet. This indicates to me that there's something that needs to be configured with the link that you're using in the widget.

    I searched through the Microsoft Community and found this discussion: This link is only available to internal users

    Looks like the user resolved this through the following:

    Internal folks are using the default link copy which is internal members only. They need to hit the dropdown and select "people with existing access"

    I hope this helps!

    Cheers,

    Genevieve

  • This information doesn't seem to work for me.

    As a Microsoft Admin I set my company default links to be "Anyone with this link can View". But Smartsheet's still only can generates a internal only link. There is no option to select what kind of link you want to create. After selecting the file you are loaded back into the Shortcut Widget and the file is added to the dash board.

    After these link are created Microsoft doesn't allow you to edit the sharing permissions. This issue seems to be a issue with the Smartsheet shortcut widget.

  • Video Explains the information provided by support isnt a option.

    SmartSheet OneDrive.mp4